SQ5 Touch screen bug

Forums Forums SQ Forums SQ troubleshooting SQ5 Touch screen bug

This topic contains 36 replies, has 17 voices, and was last updated by Profile photo of SimonVB SimonVB 1 week, 3 days ago.

Viewing 7 posts - 31 through 37 (of 37 total)
  • Author
  • #112264
    Profile photo of danielaurora

    Hi Keith,

    Sorry but I’ve actually been in contact with A&H far more than what you are aware of by the sound of it. I’d be more than happy to chat about it if you’d be interested. I will also happily give you screenshots of conversations if you’d like as there is clearly a lot of previous communication that you are unaware of.


    Profile photo of KeithJ A&H
    KeithJ A&H

    Hi all,

    This bug has been fixed in the V1.5.9 release, as noted here – https://community.allen-heath.com/forums/topic/sq-v1-5-9


    Profile photo of SimonVB

    Hi everyone

    Is there a way to ‘force’ a firmware update from a USB stick without using the touch screen?

    The touchscreen on my SQ5 is has gone completely unresponsive since Saturday.
    When booting up, I was stuck on the login screen, as there was no way to select a user and log in.
    I have now tried a full ‘hard’ reset and I can get into the console because the passwords are gone, but the touch aspect of the screen is still completely unresponsive (the screen itself works fine).

    I’m assuming this is a hardware problem. But I’ve been reading up around here and I would like to try and update to the new firmware before I send it in for repair, to rule out the possibility of this being the software/firmware problem that others have experienced.
    However, obviously, I can’t perform the firmware update through the normal process, as my touch screen doesn’t work.

    Is there another way?

    Profile photo of Rafael A&H
    Rafael A&H

    Hello @simonvb,

    Please contact us to Support@allen-heath.com and we will assist you with this procedure as well as follow up in case of being a Hardware fault.

    Thank you,

    Profile photo of nottooloud

    @rafaela, just for future reference, am I understanding that there is a way? If so, is there a reason not to let us know what it is?

    Profile photo of Sypie

    For everyone with this issue (myself included):
    What brand/type of router do you use?
    How are your IP-settings? (DHCP/static)
    How many clients?
    Does it have internet connection or is it isolated?

    Profile photo of SimonVB

    Hi everyone
    An update: helped by A&H’s support service I was able to force the firmware update from a USB key without having a functional touch screen.
    I don’t know why the method for this forced update is not (yet) shared here, but I feel it’s up to A&H and not myself to do so.
    In any case, since this firmware update to V1.5.9, everything is working fine again!

    @sypie, when my touchscreen was unresponsive, I tried several times to reboot with no network cable connected, and it didn’t make a difference. Other people’s mileage may vary, of course.

Viewing 7 posts - 31 through 37 (of 37 total)

You must be logged in to reply to this topic.