Xone:DB4 issue

Forums Forums Other A&H products Xone:DB4 issue

This topic contains 12 replies, has 5 voices, and was last updated by Profile photo of Eyreon Eyreon 16 minutes ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #99632
    Profile photo of Eyreon
    Eyreon
    Participant

    Good day to all,

    I am creating this topic since I have run out of general and creative ideas on an issue I am having.

    I am the proud owner of a DB4, in my eyes one of the best pieces of kit in my studio.
    I have been running this machine on an intel I7 3rd generation up until getting a new studio PC last week.

    I would think, download the most recent drivers, install and go..but sadly no go.

    I have installed the drivers (even in admin mode) and followed the instructions.
    After a reboot the mixer is detected and set as windows primary sound output.

    Now this here is where the fun starts.

    I play a youtube video through the mixer and the mixer lights hang, at the same time I get a page from my browser stating oops, error.
    The same went for using traktor pro 3, the software crashed with a log to export, again when the DB4 is set as its sound device.
    Setting the Maschine 3 as the primary device and there are 0 issues and no crashes.

    One would start to think this is related to network device, as did I. so I removed them all physically and disabled onboard stuff.

    Removing the DB4 drivers again made my system function correctly, this is why I am taking to these here forums to see if people have any ideas.

    I am running a Ryzen 3700x on b550 chipset.
    I am aware of certain issues on that chipset but those are only seen on the zen 3 platform, not on my zen 2 processor.
    Also I have changed the settings such as c states and PCI-E 4 to 3 as in the many guides that talk about those issues and to no avail.

    Again, I have 12 USB devices working properly and it is just the DB4 that is wreaking havoc and after careful troubleshooting, I am sure the issue is located somewhere in the driverstack.

    Seriously hoping that there is someone here that has an inkling of an idea as to what is causing this.

    #100562
    Profile photo of Eyreon
    Eyreon
    Participant

    I am guessing nobody else has any ideas, makes me sad I’ll have to replace this mixer 🙁

    #100572
    Profile photo of KeithJ A&H
    KeithJ A&H
    Moderator

    @Eyroen – Have you contacted us directly about this? If not you can do so using http://support.allen-heath.com or by emailing support@allen-heath.com.
    (There are not a huge number of XONE users in our digital community so speaking with one of the XONE experts -not me!- might be the quickest way to get help with this)

    #100574
    Profile photo of volounteer
    volounteer
    Participant

    @eyreon

    up until getting a new studio PC last week.

    Sounds like the new pc is the problem not the X1

    #100644
    Profile photo of sikisokuu
    sikisokuu
    Participant

    @Eyroen
    I have been using it since ZEN1, but all ZEN series have the same symptom in DB4.

    I made it again with ZEN4 the other day, but I got the same symptoms.
    This time, I made it with Ryzen 5 5600x, B550 chipset and VEGA64.
    I have tried various things, but the symptoms have not subsided and I am in trouble.

    I would like to know if there is a solution.

    #100709
    Profile photo of Eyreon
    Eyreon
    Participant

    I have and had 1 reply so far, this was a month ago.
    I sent another mail last week and still no reply.

    #100710
    Profile photo of Eyreon
    Eyreon
    Participant

    So far, the X570 and B550 USB issues are resolved with the latest AGESA update from AMD, this does NOT solve the issue I am having with the DB4.
    The USB problems are only on ZEN3, I am running a Zen2 (3700x)

    I have isolated the problem down to the drivers of the DB4 being the culprit, sadly the mail I got back from A&H support stated there were no known issues.
    Yet the problems arise after installing the latest DB4 drivers, all other USB devices work like a charm 🙂

    I have also raised a ticket with NI since traktor 3 is crashing, they offer extensive tooling for system diagnostics to determine what is going on, I am hoping this hands me what I need to point out and isolate the driver as being faulty.
    I have also sent them the error log that T3 generates, waiting for feedback now.

    #100761
    Profile photo of djtommygon
    djtommygon
    Participant

    I had the same problem with the DB4 on my Win10 PC (AMD RYZEN 5 3600X 3rd Gen in an ASRock B550M-HDV AM4 mobo).

    Traktor and other audio apps were crashing. I started a ticket with A&H and they concluded it was a DB4 hardware issue. So I got another brand new DB4. Same thing. It’s possible that the AGESA 1.2.0.2. Bios update might fix it, if it is indeed an USB connectivity issue. But I couldn’t take the chance and returned the DB4 while I could.

    Picked up a Kontrol S4 MK3 instead. No issues.

    #100774
    Profile photo of Eyreon
    Eyreon
    Participant

    Awesome feedback,

    That makes for 3x the same issue on ZEN chipsets.
    The new AGESA update is not doing anything for me, I have been fiddling around on Friday and even went with yet another clean install, no effect.
    This leads me all the more to IT being a driver issue with the DB4 provided drivers, they seemingly are out of date for this newer chipset and the way the chipsets handle their routing.

    It kind of makes sense, the last driver update is from 2016, ZEN came on to the scene later. thus this is a key area to look at.

    #100776
    Profile photo of djtommygon
    djtommygon
    Participant

    Yeah, I tried everything. Several weeks I worked with it, but couldn’t get it to work with Traktor for more than a minute or two. Serato worked somewhat but would also crash often at startup. And the DB4 is not even compatible with the new Mac OSX Big Sur. Kinda limits your potential and future resale value.

    #100787
    Profile photo of Eyreon
    Eyreon
    Participant

    I agree,

    Honestly, if the system is still being built and sold it should also have up-to-date drivers.
    I am guessing because the driver development is outsourced this might be some cost, but support is needed with operating systems that evolve.

    I have boiled everything down to it being the drivers of the DB4 now, I could rule out several factors because any other interface works fine.
    RME fireface > works
    Traktor Audio 6 > works

    no crashes or weird system errors.

    I have tried the db4 on both my Ryzen systems on an X570 and B550 chipset and the issue occurs.
    I have tested with Intel platform and there is no issue (at least not on the 7th Gen)

    #100807
    Profile photo of Eyreon
    Eyreon
    Participant

    Allright I am now a step closer to solving this issue,

    Support sent me a different firmware which keeps Traktor stable.
    But now my system is having errors on the DB4 driver and either does weird stuff in my browser, causing websites not to load with a DNS error message.
    Or it dies with a BSOD, which in terms of Windows 10 means there is big doodoo.

    I will dig deeper with support.

    #100887
    Profile photo of Eyreon
    Eyreon
    Participant

    @sikisokuu
    @djtommygon

    Both of you, id like to ask you to raise tickets with A&H support about the same issues you are having.
    They are stating that this has been unknown until I raised a ticket and if they don’t have any other references other people might get screwed by this as well.

    So what happened is simple, I have gone through pretty much every step there is to sort out and locate the issue.
    Ended up reinstalling windows several times and with help from Traktor support found out there is an audio transfer problem.
    It even got as far as a system crash stating that Xone_db4.sys was the culprit for the BSOD the mixer is generating.

    I have been able to reproduce the BSOD on 2 different systems with the same steps, it being a B550 or X570 AMD-based system.

    To recreate the Bsod on AMD B550/X570 Chipset machines.

    On a clean windows install!

    – Turn off DB4
    – Disconnect DB4
    – Install the latest DB4 drivers
    – Windows reboots
    – connect the DB4
    – Turn on DB4

    BSOD! stating Xone_db4.sys crashed.

    So support went along and tested but found no problems (clearly pointing out this is an AMD only problem) and found out they are running an intel-based system thus no issues.
    I have two systems available that I am willing to test with to sort the problem out but until further notice, my ticket has been closed with, in short: “sorry we don’t have any AM D systems to test with so we asked the engineers and Ploytec”

    Now for a 99% certainty, I can say the problem is related to the outdated Ploytec driver…

    In the meantime, I have a defunct piece of kit that I can do fuck all with in regard to digital mixing with software.

    So I am deliberating what to do now since I mix both digitally with external drum computers, I had high regards toward A&H gear but this sure hit me in the groin pretty hard 🙁

    Unsure now whether I should get a Xone:96 or go back to Pioneer.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.