Xone:DB4 issue

Forums Forums Other A&H products Xone:DB4 issue

This topic contains 31 replies, has 10 voices, and was last updated by Profile photo of Dyve Dyve 3 weeks, 3 days ago.

Viewing 15 posts - 16 through 30 (of 32 total)
  • Author
    Posts
  • #100890
    Profile photo of volounteer
    volounteer
    Participant

    The lead topic for this discussion was
    Xone:DB4 issue

    and KeithJ A&H said
    (There are not a huge number of XONE users in our digital community so speaking with one of the XONE experts -not me!- might be the quickest way to get help with this)

    Sorry if not spelling out << 1 >> as << one >> confused you so much

    But that is irrelevant as your problem started when you changed the PC out for a new one.
    You need to prove the PC is NOT the problem before blaming AH gear

    #101133
    Profile photo of Plankton Jnr
    Plankton Jnr
    Participant

    I’m experiencing exact same issues. Ryzen 5900x paired with a Asus x570i motherboard. Same symptoms, applications crashing, YouTube causing lights to hang and my web browser to show “status access violation” error.
    We’re in the same boat, if you get any new updates could you let us know? I’ll do the same.

    I’ve made the fatal mistake of selling my audio interface before testing the Db4’s sound card, ended up being left without.

    #101134
    Profile photo of volounteer
    volounteer
    Participant

    do you have the latest firmware
    https://support.serato.com/hc/en-us/articles/115000287933-KNOWN-ISSUE-Allen-Heath-XONE-DB4-DB2-connect-but-won-t-play-audio-on-Windows

    if so then blame windoze and its drivers if you get no sound

    #101135
    Profile photo of volounteer
    volounteer
    Participant
    #101155
    Profile photo of djtommygon
    djtommygon
    Participant

    @Plankton

    Exactly. I had web browser “status access violation” errors too. Only when the DB4 was connected via USB and powered on. Hasn’t happened since I got rid of the DB4.

    @ volounteer aka https://community.allen-heath.com/members/williamadams/

    Not helpful dude. But thanks for trying.

    #101160
    Profile photo of volounteer
    volounteer
    Participant

    @djtommongon

    glad to hear you fixed your problem
    sorry you did not find it useful
    you would be surprised how many people do make simple mistakes by overlooking something like that

    not sure why you doxxed my link on AH
    anyone can click on my screen name and get it for themselves

    #101343
    Profile photo of Eyreon
    Eyreon
    Participant

    Alright,

    Minor update from my side, I will ignore Volounteer, since he is only trying to point at m,y initial problem. not helpful.

    I have now been able to reproduce the problem on 6, 6!!! machines, all running AMD Ryzen.
    I tried 4 Intel machines and no problem.

    I know without a doubt, the problem is the Ploytec driver that comes with the DB4.
    The error message on BSODS stating it and being able to reproduce this makes it clear.

    I can also pinpoint where the problem is located in the way the driver functions.
    This has to do with the different ways that AMD and Intel handle their memory access and use of the CPU fabs on AMD.
    Should not be a big issue to fix but I can see that investing that in a mixer that is still being sold and made is too much.

    It pains me to say that ill have to get rid of the DB4 and go for something else like the Xone:96 which is core compliant and doesn’t rely on 3rd party shizz.
    Shame I have to dish out another smack of money for something like this 🙁

    #101400
    Profile photo of Oxy
    Oxy
    Participant

    Having similar issues. BSOD when the unit is turned on or off. This can be prevented by turning the DB4 on before you boot the computer.
    XoneDB4.sys is the culprit.

    This is on an all Intel 10th gen system.

    #101406
    Profile photo of Eyreon
    Eyreon
    Participant

    @Oxy,

    This is similar behavior to what causes the crash on my AMD machine.
    When turned on prior to starting the PC this doesn’t happen.
    But still, the sound hangs/youtube doesn’t play/network errors keep rising thus making the machine problematic.

    I Sold my DB4 today, got a fair price fr it, will look into a new mixer.

    #101414
    Profile photo of Oxy
    Oxy
    Participant

    I just found out there is additional firmware for the audio device in the DB4. This is not clear on the web page, but this update seems to have resolved the issue with the blue screen. Tried to replicate the problem after updating but it has not happened since. Also, my DB4 came with firmware 2.2.3 (2017), there is no mention of this version ANYWHERE to be found. So it seems strange that a new purchased DB4 comes with newer firmware on it then stated on the website, even weirder is that the audio device firmware was not up to date. Very confusing, the A&H website should mention more clearly about the 2 different firmwares that can and/or must be updated.

    I don’t think I want any other mixer after this. The input matrix and effects already made them selves invaluable and none of the other mixers on the market offer any functionality that comes close.
    The only thing I would consider is the Model1 but that does not have effects nor an audio interface. Can live without the effects but a decent audio interface runs at least a few hundreds, if not more plus added cable clutter.

    Did not have much time yet to test it, but it made BSOD’s all day when plugged in (USB) and turning it on/off would result in a complete system crash almost every single time.
    So fingers crossed, will update here if it’s not resolved.

    #101439
    Profile photo of Eyreon
    Eyreon
    Participant

    Glad to hear you solved your issue!

    I tried working with A&H support on the updates and they have been very forthcoming in trying to resolve the issue with the tools they have available.
    For me this had no effect sadly.

    Actually there are three different tools to use on the DB4.

    – Mixer firmware
    – soundcard firmware in the DB4 (ploytec)
    – driver

    #101721
    Profile photo of Oxy
    Oxy
    Participant

    I have a different issue. The DB4 sometimes is not recognized by the computer. Had to cancel a night of playing in a bar because I could not produce sound, very embarrassing.
    At home, I tried for 2 days, nothing. Then I plugged it into a different Win10 machine (after installing drivers) and all was well. So I plug it back into the laptop, and there is was, like nothing ever happened. Needless to say, the bar won’t see me back again.

    Do I need to send this thing back and beg for a replacement ?

    Again where is the info on firmware version 2.2.3 A&H?

    #101929
    Profile photo of jahroyal
    jahroyal
    Participant

    Been anticipating Buying either 2 Xone DB4’s
    2 Xone 96’s
    OR Xone DB4 and Xone 96 together for a DAWless setup of Synth Heavy Live Performance(jamming) home studio

    I have found similar issues in post/after installing Windows 10 it has been impossible to get my Synaptics Pad to work w/out having to uninstall after restart(Device Manager) and restart the Laptop yet again… Driver’s are Bane of existence.

    Quite possibly: contention, hacker’s choice of most stable firmware(operating system/chip-set)/// or most compliant logistical Operating Systems may be only hope.

    #101959
    Profile photo of Oxy
    Oxy
    Participant

    Completely baffled over here. It has not happened since. Now I even use it through a Thunderbolt3 dock. Really love this thing!

    #102734
    Profile photo of luckyHitaki
    luckyHitaki
    Participant

    Your post came in a little late…
    I was using a surface pro 4, but the screen suffered of flickergate; so it was time to get a new PC in March.
    The new Mac M1 looked awsome but internet was saying that lots of audio software is not working with the new macs….
    I contacted Allen Heath to confirm this and in fact M1 is not supported.

    Now stupid me thought, Zephyrus G14 looks good. AMD core of course.. Who would have thought that it would cause issues? At the end its windows 🙂

    Anyways, my experience so far (Xone DB2 user):
    – PC going crazy after a while, Chrome extensions are crashing, chrome is crashing while mixer is plugged in.
    – no BSODs but PC gets unusable due to the funkyness
    – latest firmware on mixer and latest driver on PC is installed. (Firmware updater does only worked through my old IMAC)

    At least you guys with a DB4 can hope for a new driver 🙂 I assume the discontinued DB2 wont get any.

Viewing 15 posts - 16 through 30 (of 32 total)

You must be logged in to reply to this topic.