Qu-16 USB-B Distortion & Gain – There's a Duck in My Mix

Forums Forums Qu Forums Qu DAW integration Qu-16 USB-B Distortion & Gain – There's a Duck in My Mix

This topic contains 18 replies, has 4 voices, and was last updated by Profile photo of Miles J Miles J 1 week, 2 days ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #92051
    Profile photo of Miles J
    Miles J
    Participant

    Hi everyone, thanks in advance for any advice you can provide a newbie to Qu –

    I made a first attempt at recording from a Qu-16 USB-B stream to Logic (Logic Pro 10.5, iMac 2019 Catalina). Two things happened that I don’t understand:

    1) A regular but inconsistent burst-distortion sound on playback, which occasionally sounds like a duck. I’ve attached a recording made on my phone from the monitor output. The signal recorded cleanly, it does not seem to be the actual signal that is distorted, but some kind of digital artifact. What did I do wrong? This leads to my second question:

    2) The recording signal level indicated in the DAW is lower than the level indicated on the Qu channel. The Qu channel can be close to peaking out, and the Logic level still reports plenty of headroom. I see there is a trim control for channel USB assignments, but this shouldn’t that only affect the USB return signal to the mixer? Is there some method of controlling DAW channel gain independent of Qu channel gain?

    Thank you!

    Attachments:
    You must be logged in to view attached files.
    #92053
    Profile photo of volounteer
    volounteer
    Participant

    @milesj

    2 – for sure it is correct.
    The AH has an extra 18dB headroom past the lights.
    You need to normalize the level in the mac to match what you think it should be or what you want.
    On my PC DAW I can see the level coming in and set it to record higher. Or I can record low then increase it before processing.
    I prefer to record low and then adjust the level later to avoid clipping.

    1 – I would suspect it is the mac and your settings as well as other bloatware that might be interfering. Be sure your antivirus is killed dead before you record audio. buffers and drivers are also a big cause of the problems. I do not suspect it is the AH causing the problem.

    If that was a wav file windows could not play it.

    #92056
    Profile photo of Miles J
    Miles J
    Participant

    Thank you… regarding #2, I will give a try to bumping up the level from the Qu.

    Regarding #1, I can play back the file with no problem at all on the interface I recorded it with. It’s only once I connect to the Qu that the problem shows up, so while the problem may be with the Mac, it is something to do with the Mac/Qu combination.

    #92057
    Profile photo of volounteer
    volounteer
    Participant

    @milesj

    I still suspect the mac part of the mac/qu combination.

    why do you need to record at a higher level?
    you can always do better by adjusting it after recording while removing dc offset and normalizing to whatever level you want.
    else turn the knob on the output amp to the right to make it louder.

    #92058
    Profile photo of Steffen R
    Steffen R
    Participant

    the gain staging in the desk and in the DAW are different

    since the QU is foremost a live sound mixer it is essential to have some headroom to avoid clipping from processing
    so the maximum output is reached if the signal is going far beyound the 0dB point of the internal processing

    as volounteer writes… 18dB and that’s a lot 😉

    why do you need to record at a higher level?

    higher recording level provide a better signal to noise ratio

    to the first point: I listened to your recording and it sounds like somethinmg is happening in the background

    #92059
    Profile photo of volounteer
    volounteer
    Participant

    @SteffenR

    The S/N for digital is so huge you could have an even bigger headroom and never hear any noise due to digital.
    Any noise will come from other causes.

    My first tape machine had 40dB SNR in the early 60s. Digital must be 3-5x that depending on the bit width.
    And floating point might as well be infinite.

    #92060
    Profile photo of Steffen R
    Steffen R
    Participant

    And floating point might as well be infinite.

    but to record floating point is out of reach for most of us…
    only two devices I know can record 32 bit floating point audio
    one Sound Devices and one Zoom recorder

    and it is still good practice to record with highest signal to noise ratio possible

    #92061
    Profile photo of volounteer
    volounteer
    Participant

    @SteffenR

    A number of DAWs can do floating point.
    You do not need to record 32 bit, just process in it and convert before saving.

    It is better practice to avoid clipping.
    And leaving extra headroom to avoid errors in A/D/A when you are near the maximum is better than a few more bits of SNR.

    24 bit gives DR of about 144dB.
    use 18dBFS for headroom and add 6dB for total of 24dB to get better A/D/A, and you still have 120dB DR.

    I note a number of professional groups use 24dB as their operating point.
    30dB would be better and you still have SNR of 114dB which is way above analog and way more than you need or could use.

    http://al-ba.com/wp2/wp-content/uploads/2014/12/conted2.jpg
    this is not the best but it was the only one I found quickly with a reasonable diagram showing analog vs digital.
    ignore the silly comment about analog clipping on the diagram.

    #92063
    Profile photo of Steffen R
    Steffen R
    Participant

    A number of DAWs can do floating point.
    You do not need to record 32 bit, just process in it and convert before saving.

    actually this is not the same as recording in floating point

    and I know all your mentioned things already and did not say you are wrong
    just to add some more information

    something to read

    32-Bit Float Files Explained

    but all of this does not solve the initial problem, so we wait until @milesj answers

    #92066
    Profile photo of Miles J
    Miles J
    Participant

    Steffan, thanks for your reply. The noise in the recording was not from the background – I experimented with recordings made with the Qu and also a Focusrite interface, with the same computer. Here are the results:

    Recorded on: Played back on: Result:
    Qu Qu Noise
    Qu Focusrite Noise
    Focusrite Qu Noise
    Focusrite Focusrite No Noise

    So the noise is related to the Qu USB interface in some way. I thought it could have been related to sample rate, but the sample rate in Logic is set to 48 kHz.

    #92067
    Profile photo of volounteer
    volounteer
    Participant

    @SteffenR

    Thanks for the additional info.
    Yes, float gives you a virtual guarantee against clipping which is the main reason for headroom.

    @milesj

    Not sure what you mean by Qu Qu noise. Just how did you record the Qu on the Qu and then playback on the Qu while using the usb?

    I could agree with your data if I understood exactly what you did, but still say it is the problem of the mac and its settings.

    I note that your wav failed to playback on my pc. And all the symptoms tend to point to opsys driver buffer crapware and other settings or programs in the mac being the problem.

    #92068
    Profile photo of Miles J
    Miles J
    Participant

    Haha oops! I guess formatting of these messages doesn’t come out the way it looks. What I mean is,

    If I record through the Qu and play back through the Qu, I get the noise.

    If I record through the Qu and play back through the Focusrite, I get the noise.

    If I record through the Focusrite and play back through the Qu, I get the noise.

    IF I record through the Focusrite and play back through the Focusrite, everything is fine.

    So, if the problem is with the Mac, it has something to do with the unique Mac-Qu interface, since it works well with the Focusrite.

    #92069
    Profile photo of volounteer
    volounteer
    Participant

    @milesj

    That I believe.
    And I still strongly suspect a mac/opsys/driver/crapware/buffer/yada_yada problem.

    Is there any difference in ANYthing when you use the focusrite?
    That includes defaults you do not set, or options you did set which defaulted on the Qu usage.

    Does the Qu work okay on anything else?
    If so then that eliminates the Qu and pins it down to the specific interface mac-Qu.
    AFAIK you can’t really change options drivers yada yada on the Qu so that points to the mac needing to change something.

    #92070
    Profile photo of Miles J
    Miles J
    Participant

    The only thing I changed in Logic was the sampling rate, to be consistent with the Qu’s 48 kHz rate.

    I haven’t tried it with anything else yet. The user guide says USB DAW streaming is only implemented for Mac – has that been updated?

    #92071
    Profile photo of volounteer
    volounteer
    Participant

    @milesj

    That has to be okay, for the Qu to use 48 with it, but could that change cause the mac problems if it worked at a different rate with focusrite?

    What was the focusrite sample rate?

    Do you have the AH driver for your mac to work with the Qu?
    Wrong driver could be a problem.

    Could changing sample rate make your driver okay on FR and have problems on Qu?
    Sample rate change might also affect buffer sizes needed to work correctly.

    A number of places have long articles on what to do to a PC to make it work well with digital audio.
    Is there a guide like that for your mac that you should do first to ensure you avoid problems?
    Strongly recommend you check that and failing that still remove everything that is not audio related and only use the mac for audio. Trying to use a PC for audio and other things too often leads to many problems. Win10 is even worse than previous versions were.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.