GLD Editor resolution

Forums Forums GLD Forums GLD troubleshooting GLD Editor resolution

This topic contains 8 replies, has 5 voices, and was last updated by Profile photo of Scott Scott 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #53508
    Profile photo of extraCheese
    extraCheese
    Participant

    Hi here !
    I’m having an issue with GLD’s editor’s software resolution. I recently installed it on my Surface Pro 4. It has a 12.3″ screen with a 2736 x 1824.

    The problem is that the interface is ridiculously small. About the size of my thumb in diagonale!
    Here I joined a capture of the window. The size you can see is irrevelant but if you look at the “Connection” button and consider the text is the same size as your interface, you’ll understand the problem.

    So my question is : is there anyway to enlarge the editor’s window or modify its resolution?
    I really cant do anything with a windows that small..

    Thank’s !

    [sorry for typos, I’m not fluent in English ;)]

    Attachments:
    You must be logged in to view attached files.
    #53515
    Profile photo of Chris93
    Chris93
    Participant

    You have a huge number of pixels on a relatively small screen, so stuff is going to be small. Unfortunately because Editor has a fixed resolution you’re sort of stuck with the problem, but variable resolution would be a good feature request.

    Is it possible to run the surface at a at a lower resolution? Also, I think I remember windows has a “disability access” mode that gives you a magnifying glass to zoom in on things, that could do the trick if it’s still a feature.

    EDIT: On Windows 10 there’s an app called “magnifier” under “desktop apps”. I just found it by searching for “magnify” in the start menu. Does this help you?

    Chris

    #53605
    Profile photo of extraCheese
    extraCheese
    Participant

    Thank you for your answer!

    Your fixes works indeed, but as temporary fixes, it’s not viable for a long term use. :\
    You mentioned a feature request, is there anyway to do such a thing?

    Thank’s again anyway !! 🙂

    #53606
    Profile photo of Chris93
    Chris93
    Participant

    Post a link to this thread in the feature suggestions section:

    http://community.allen-heath.com/forums/forum/gld/gld-feature-suggestions

    If you can take a photo of what the MS surface looks like when running Editor it may help to highlight the issue.

    Chris

    #53608
    Profile photo of mervaka
    mervaka
    Participant

    As Surface runs Windows, is it possible to drop the resolution?

    #53681
    Profile photo of extraCheese
    extraCheese
    Participant

    Thank’s I will post a request ! 🙂

    @mervaka Indeed, I cant drop the resolution but it is not suitable for a long term use having to switch resolution each time I’ve got to launch GLD Editor (I have to restart my surface for GLD Editor to use the new resolution. I can’t even switch in runtime.°

    #80163
    Profile photo of Jeggins
    Jeggins
    Participant

    I have a workaround that should work… (i have the surface book 2 and for me this workaround works perfectly)

    The problem:
    When the application load, windows asks if the app is high DPI aware and these apps answer “yes” which is why you end up with an interface for ants.

    The solution:
    Have the app tell Windows that it is not DPI aware and let it scale everything properly

    How it is done:
    1. Tell windows to look for an external manifest file.
    2. Create the external manifest file. (or just use the one i will upload here)

    Step 1:
    1. Press Windows Button + R, type “regedit”, and then click OK.
    2. Navigate to the following registry subkey:
    HKEY_LOCAL_MACHINE>SOFTWARE>Microsoft>Windows>CurrentVersion>SideBySide
    3. Right-click, select NEW>DWORD (32 bit) Value.
    4. Type PreferExternalManifest, and then press ENTER.
    5. Right-click PreferExternalManifest, and then click Modify.
    6.Enter Value Data 1 and select Decimal.
    7. Click OK. Exit Registry Editor.

    Step 2:
    1. Navigate to the application folder of the GLD 80 Editor.
    2. Rename the “GLD Editor.exe” to “gldeditor.exe” because whitespaces always suck in filenames.
    3. Rename the .txt file i addet from “gldeditor.txt” to “gldeditor.exe.manifest”
    4. Copy the manifest-file, I uploadet into the application folder

    Done!!

    I hope this can fix the Problem for you guys, too.

    Alex

    #80164
    Profile photo of Jeggins
    Jeggins
    Participant

    OK sorry that no file is included but I am not allowed to upload even .txt files…

    so you guys have to create your own manifest file.

    1. create a .txt file and name it however you want.
    2. copy the code from here to your .txt file and save it.
    3. rename the .txt file in “gldeditor.exe.manifest”.
    4. Copy the manifest-file into the application folder

    #80186
    Profile photo of Scott
    Scott
    Participant

    You can also right-click on the GLD editor icon, then select “Properties”, then go to the “Compatibility” tab page. In the mid section check the option “Disable display scaling on high DPI settings”, and click Apply.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.