SQ7: USB crashing MaxMSP

Forums Forums SQ Forums SQ troubleshooting SQ7: USB crashing MaxMSP

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of chrisc chrisc 2 years, 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #85469
    Profile photo of chrisc
    chrisc
    Participant

    Hi all,
    Has anyone else had trouble using the USB inputs on the SQ as a playback device for Max verson 7/8 on Mac? Every time I select the SQ as an output device, Max crashes or stops outputting audio. I have tried this using both Max 7 and 8 on several machines using the standard Mac core audio drivers. Depending on the machine, Max completely crashes (and exits) or freezes and won’t output audio.

    I have tried all the Max recommendations for fixing crashes, no joy. I have also tried outputting from Max at several sample rates.

    I am able to use the SQ as a USB device for all other programs that I have tried, just not Max. I can even use sound flower to patch audio from Max into Logic then out to the SQ7, but this adds too much overhead and lag for live processing.

    I have several shows this week (starting in a few hours) that need this system up and running, so I have a few artists sweating it out right now. We have a fall back option, but it’s pretty janky, so any suggestions or advice are appreciated at this stage.
    Cheers,
    Chris

    #85482
    Profile photo of Alex A&H
    Alex A&H
    Keymaster

    Hi Chris,

    I’m sorry to hear you’re having trouble here!

    As the SQ is working with other programs, it does point to Max causing this issue. Have you contacted their support department to see if there is anything they can do?

    If you would like to go through some troubleshooting, please start a ticket at support.allen-heath.com for further assistance.

    Thanks
    Alex

    #85484
    Profile photo of chrisc
    chrisc
    Participant

    Thanks for the quick response Alex!
    Looking at the crash report, it appears that the default Apple core audio driver is crashing when querying the properties of the DI32 (I assume the 32 channel digital interface in the SQ?)
    I have raised a ticket with the Max people and will raise a ticket with you if it looks like it might be a hardware thing.
    If anyone else is having this issue, you can switch the driver inside Max to be ad_portaudio instead of the default Core Audio. This seems to fix things, not sure why and uncertain if this driver has other limitations or issues.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.