SQ5, AR2412, AR128 and networking.

Forums Forums SQ Forums SQ general discussions SQ5, AR2412, AR128 and networking.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of danny danny 1 month, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #92156
    Profile photo of danny
    danny
    Participant

    Hello,
    There are a few posts in the forum that say the networking that the Audio Rack devices are simply a Layer2 protocol, and can work with switches…
    So I’ve been doing some “experiments” at home… results, (and questions) below.

    First…
    Obviously plugging the devices from the SQ Slink port out to either box directly just works.
    Desk (slink) -> (slink) AR2412, works (24 extra inputs available)
    Desk (slink) -> (slink) AR128 works (12 extra inputs available)

    And plugging the devices in “by the book”, (attaching the AR128 to the expansion port of the AR2412) also (obviously) works.
    Desk (slink) -> (slink) AR2412 (expansion) -> (slink) AR128 (32 extra inputs available.)

    (hopefully that’s all obvious, but explains how I’m listing the connections.)

    now trying to put an Ethernet switch in the middle between the desk and the audio rack box.
    Desk (slink) -> (eth0/1) switch (eth0/2) -> (slink) AR2412 -> works…
    or appears to, extra channels are available, and audio is passed, but I don’t have the capacity to test all the channels at once, the link/err light shows red instead of orange, but it is not clear why.

    I get the same result for:
    Desk (slink) -> (eth0/1) switch (eth0/2) -> (slink) AR128
    Desk (slink) -> (eth0/1) switch (eth0/2) -> (slink) AR2412 (expansion) -> (slink) AR128
    and… Desk (slink) -> (slink) AR2412 (expansion) -> (eth0/1) switch (eth0/2) -> slink AR128 works, channels show up, passes audio, but red lights show…
    (basically a red light for whatever device plugs into the switch, but I see channels hear audio in limited testing.)

    So seems pretty good so far…
    So the next tests are… Can I plug the desk into the switch, and the audio racks both into the switch. (all in default VLAN / using cheap unmanaged switch.) – the answer is a definite no this doesn’t work.

    Desk (slink) -> (eth1) switch
    Switch (eth2) -> (slink) AR2412
    Switch (eth3) -> (slink) AR128
    again, red links on the link/err lights on the unit, but also, the first device you plug in, is likely to show up, and might pass audio for a bit, but eventually it seems that there is some conflict in the devices. eventually I only have desk inputs, all slink ports are greyed out.

    that’s the last tests that can be done with a cheap switch, so the next tests (if anyone wanted to copy this) must be done on a managed switch. (config posted is for Cisco devices…)

    Desk (slink) -> (eth0/1 [vlan2]) switch
    Switch (eth0/2 [vlan2]) -> (slink) AR2412 (expansion) -> (eth0/3 [vlan3]) -> switch
    Switch (eth0/4 [vlan3]) -> (slink) AR128

    (switch configuration)
    interface FastEthernet0/1
    description from desk
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/2
    description to AR2412 slink
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/3
    description from AR2412 expansion
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/4
    description to AR128 slink
    switchport access vlan 3
    switchport mode access

    For those without the IT background, using VLans (virtual LANs) is a way of “splitting” the switch so that there are different broadcast domains, (so you can use 1 switch where otherwise there might have needed to be 2.) (so this is like putting 1 switch in between the desk and the AR2412, and a different switch between the AR2412 expansion port and the AR128.

    Anyway… this also appears to work! I see all the channels on the desk,
    BUT all the link/err lights show red (not yellow).

    Again, I’ve tested sending a few channels of audio, – audio reaches the desk, but at home I don’t have the option of sending a “whole show” to the desk…

    so… long, long, long introduction aside, three simple questions.

    1, Has anyone else done this, did they get the same result?
    2, What is the importance of the red link light? – does this specify error? will audio have jitters/cuts/stutters etc?
    3, switch speed – I’ve tested with an old 10/100 switch, would using a Gb switch make a difference?

    #92159
    Profile photo of Andre S
    Andre S
    Participant

    Hi Danny,

    I´m not sure, I´ve ever seen an AR128. I know AR2412 and AR84. The only one with 12 is a DX012. Did I miss something?

    Cheers.

    #92160
    Profile photo of SteffenR
    SteffenR
    Participant

    there should be no testing required to find out how it works…

    the old AB racks require Fast ethernet, that means 100MBit
    if you plug them to a GBit switch they won’t work because the link doesn’t work
    RED LIGHT! means not working at all

    GigaACE and SLink are GBit
    dSnake and ME is 100MBit only

    https://www.allen-heath.com/media/DX-gigaACE-white-paper-1.pdf
    https://www.allen-heath.com/media/SLinkConnections_V1_5_0.pdf

    #92161
    Profile photo of danny
    danny
    Participant

    Andre… sorry, my (idiot) mistake, I put the boxes away before making the post, so didn’t have them right in front of me to read the model numbers.

    Devices are AR2412 and AR84. (older GLD branded ones.)
    (That should also clarify of course the ports on the boxes are dsnake. -not slink)

    Steffen,
    I think the DX white paper is exactly what I need, ports are in 100mb mode, but negotiated there – the paper indicates this *may* cause issues, I’ll see if configuring the port speed resolves the red light.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.