Mac m1, latest os and QU32…does it work?

Forums Forums Qu Forums Qu DAW integration Mac m1, latest os and QU32…does it work?

Tagged: 

This topic contains 2 replies, has 3 voices, and was last updated by Profile photo of pt. pt. 1 week, 5 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #105975
    Profile photo of Longy
    Longy
    Participant

    Hi all, considering getting a new Mac, but before I do I was wondering how many are successfully using the QU32 with it for audio streaming to and from DAW?
    How are you dealing with usb c to usb b conversion and any issues with glitchy/noise bursts during recording or playback.

    I would rather not change what seems to work but my imac is getting old in the tooth now. Contemplating either a macbook pro or mac mini m1.
    I do most of my recording in Ableton, streaming both to and from (when using outboard processing).

    Any info would be great, don’t want to spend a couple of K for something that isn’t going to work.

    It still shocks me that Allen & Heath have failed to resolve this issue and seemingly washed their hands with it, especially given the cost of these mixers. Last time I purchased an item that didn’t work as advertised the company replaced it with one that does without extra cost….seems A&H are more interested in building new mixers and leaving many in the lurch.

    #106003
    Profile photo of KeithJ A&H
    KeithJ A&H
    Moderator

    @Longy

    The Qu is class compliant and supported with Intel and M1 Mac’s running Monterey, so you should be all good!
    Note that official support is for use with official adapters (USB-C to USB) and with a direct connection – that’s not to say other adapters don’t work, but if you run into issues, the first thing we’re going to check is that you’re using Apple adapters.

    I’m not sure what you mean about failing to resolve an issue – there is plenty of discussion about the lack of support for USB2.0 isochronous transfer with some intel USB3+ USB host controllers in the sticky thread here and we’ve worked with every individual who’s been in contact to try and figure out the root of their particular issue.
    That’s if they’re still having one after the V1.95 update, as this solved the issue for most who were experiencing it, especially those running Mac’s.

    Thanks,
    Keith.

    #107175
    Profile photo of pt.
    pt.
    Participant

    Hi, I’m using a Mac mini M1 with the Qu-Pac and it’s running great. The Qu-Pac is connected to a Twelve South StayGo USB-C hub that has three USB-B connections, Ethernet and HDMI. It’s running very stable and no glitches at all. Make sure to upgrade the firmware of the Qu to at least 1.95 – I initially had older firmware and this was glitching like crazy.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.