How to use CQ-20B as computer audio interface (not only through DAW)

Forums Forums CQ Forums CQ troubleshooting How to use CQ-20B as computer audio interface (not only through DAW)

This topic contains 15 replies, has 7 voices, and was last updated by Profile photo of TheAngryPenguin TheAngryPenguin 2 weeks, 2 days ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #118625
    Profile photo of Dupinguez
    Dupinguez
    Participant

    Hello everyone,

    Very new to A&H gear, and to digital mixers in general, sorry if that question has already been answered a thousand times before!

    So, I get that, when connected via USB to my computer, I can use my CQ-20B to record any input I want through my DAW, and also hear the result, but is there anyway to use as a regular external soundcard on my computer? I mean, when watching a video on YouTube, can the sound be directed to the CQ-20b outputs so that I hear that on my speakers?

    When plugged in, I see a couple of outputs shown on Windows, (1-2 to 7-8 if i’m not mistaken), but those don’t seem to do anything when selected, I can’t hear anything from my computer on my speakers. Am I missing something or is this just not something the CQ-20b is supposed to do?

    Thank you in advance for any help!

    #118655
    Profile photo of Dupinguez
    Dupinguez
    Participant

    Also, I’d like to use any input on my CQ-20B as input peripheral on windows or any software (Discord, Skype, whatever). Is that possible?

    #118665
    Profile photo of KeithJ A&H
    KeithJ A&H
    Moderator

    @dupinguez

    There are two stream modes for the USB-B interface on the CQ.
    In CONFIG / Digital Audio (Symbols) / USB/SD you can set the stream mode to either Stereo or Multitrack.

    It sounds like you currently have this set to Multitrack, so set it to Stereo and you’ll see just the one stereo input and one stereo output device from Windows.
    The output from the CQ going to the computer will then be whatever you set for the last channel assignment pair (in the same screen as above, bottom right, labelled ‘Stereo L/R’).
    When the CQ is selected as the system output device (for music, browser etc…) the sound from the computer will be sent to the dedicated USB channel on the CQ.

    To set up for discord or skype or any other application where you don’t want to send the output from the computer back to the computer (creating a feedback loop or echo for the person at the other end) – set the Stereo L/R output to a stereo linked, pre-fade output instead of it’s default Main LR. This will mean you have total control of what you send to that output separately from what you might want to be hearing in the main mix yourself. Usually referred to as a ‘mix minus’ if you’ve not set up in this way before and want to read up on it.

    Cheers,
    Keith.

    #118676
    Profile photo of Dupinguez
    Dupinguez
    Participant

    Thank you for your reply Keith!
    I’ll try this as soon as possible.

    What is very weird for me right now, is that I see the same list in “Inputs” or “Outputs” on Windows. I’ve had a Motu Track 16 previously, and one great feature it had was that ALL the inputs were listed on Windows to be used on various softwares (very good if you wanna give online piano lessons for example). Any chance that would be possible or added in the future?

    #119858
    Profile photo of WORT-FM
    WORT-FM
    Participant

    I’m in a similar situation, I have the CQ set up to record in Audition and it records just fine but in order to hear the playback I have to go into CONFIG / Digital Audio (Symbols) / USB/SD and set the stream mode to “stereo” (as you suggested here) But this switch then renders all the inputs to a single LR stereo pair. Is there a way to set the interface so I can hear and record without having to change the stream mode?

    #120109
    Profile photo of Misantropen
    Misantropen
    Participant

    @KeithJ A&H

    How would one go about this specifically on the CQ18T in regards setting the Stereo L/R Output to a Stereo Linked Pre-Fade Output instead of it’s default Main LR?

    I did not understand this to my avail.

    I’m also trying to use the mixer casually with discord, and the feedback is annoying to say the least.

    #120118
    Profile photo of KeithJ A&H
    KeithJ A&H
    Moderator

    @wort-fm

    The stereo USB channel either receives from USB channels 1&2 when the USB stream mode is set to stereo, or from higher channel numbers (depending on model) when USB stream mode is set to multitrack.
    You can see the source for any channel in the PROCESSING / Input Preamp screen when it’s a Complete Channel – https://www.allen-heath.com/content/uploads/2023/09/CQ_User_Guide_V1_1_0_iss1.pdf#page=79&zoom=auto,-361,588

    So to return a stereo feed from a DAW, you should match the output channel number to the USB source channel number displayed.

    @misantropen

    setting the Stereo L/R Output to a Stereo Linked Pre-Fade Output instead of it’s default Main LR

    The last 4 stereo USB/SD outputs of the CQ-18T are set in the CONFIG / USB/SD/BT / USB/SD screen – https://www.allen-heath.com/content/uploads/2023/09/CQ_User_Guide_V1_1_0_iss1.pdf#page=64&zoom=auto,-361,555
    Then the final stereo pair of these is the one used when USB streaming is set to stereo, which by default is Main LR.

    Hope this helps!
    Keith.

    #120566
    Profile photo of GoodOlJoe
    GoodOlJoe
    Participant

    I own a CQ12T and created a (simplified) schematic of the USB routing to and from a USB-connected computer. The schematic depicts Multitrack mode only. Now that I understand it, the routing is straightforward but it was a little hard to get my head around initially for several reasons. If you’re reading this thread because you can’t figure out the USB routing, don’t feel bad. The mixer UI is generally intuitive, you’re not alone if you find the “Channel Assignment” part of the UI very un-intuitive.

    1. It contains insufficient information to tell you what you’re really mapping, or even which direction (input or output). It’s obvious once you understand it, but to a new user coming from other mixers, it’s not obvious at all. Even the tab label under Configs is not helpful: Other tabs are labeled Config, Inputs and Config, Outputs which set the context for the whole tab. But Channel Assignment settings are on a tab labeled Config, USB/SD and the words input or output don’t appear anywhere so there are no clues to what direction you’re mapping. A redesign of the visual labeling and layout of Channel Assignment would help a lot.
    2. There’s incorrect labeling in the CQ Mixpad app which labels the output USB channel pairs as 17/18, 19/20, and 21/22 when, on a CQ12T, they are really 11/12, 13/14, and 15/16.
    3. In Windows 10, the output devices exposed by the ASIO driver (output from Windows perspective) are labeled CQ 1&2 (ST IN), CQ 5&6 (USB) and CQ 7&8 (BT), but those actually correspond to USB channel pairs 11/12, 13/14, 15/16.
    4. It’s also confusing because six of the assignable items are CQ outputs (Main LR, Out1/2, etc.) but one is a CQ input (ST IN). It makes you think you might be mapping PC-channels-to-CQ-Inputs.

    Regardless of these issues, it’s a great mixer, and the USB interface is easy to use once you get your head around it.

    Perhaps this schematic will be helpful to others (and I sure hope it’s correct!)

    Attachments:
    You must be logged in to view attached files.
    #120572
    Profile photo of TheAngryPenguin
    TheAngryPenguin
    Participant

    I am still super confused about this. Having to flip the input source to USB/SDHC on all 16 channels just to play back a multi-track recording is a royal PITA. And more times than not, when flipping back to Analogue, channels that had Auto Gain enabled before no longer have it enabled. And what about overdubbing? [CQ-20B, MacOS, Reaper]

    #120575
    Profile photo of GoodOlJoe
    GoodOlJoe
    Participant

    @TheAngryPenguin

    I don’t know your specific scenario, but in my scenario I don’t flip input sources back and forth. I’m using the CQ12T as an input mixer to my DAW running on the computer. I keep the CQ12T in stream mode “Multitrack”. All the channels with physical input jacks are set to Analog inputs and stay that way. Whatever signal comes in via those analog inputs gets sent out to the DAW on the same-numbered USB channel. So if I’m tracking guitar, I set the input channel on the DAW track I’m recording to the channel my guitar is plugged into. Keyboard tracks get input from the keyboard channels, and so on.

    For playback from the DAW, I’m mixing in the DAW, not on the CQ12T. The only output back to the CQ12T is a stereo pair containing the output of the DAW’s master bus (the whole stereo mix). The master bus in my DAW mixer sends audio out via the two USB channels that go to the CQ12T’s input channeled labeled “USB”. Those channels are 13 & 14 for the CQ12T, they’re different for the CQ20, maybe 21 & 22 but not sure. The CQ12T input channel labeled “USB” has no analog input jack, it’s dedicated to audio coming in on just those two specific USB input channels.

    As for overdubbing, you said Reaper so I assume you’re talking about recording to Reaper not to an SD card in the CQ12T. So overdubbing is just like any other kind of recording, you hit arm the track you want to record, the rest are playing back. The master bus is sending the mixed playback out to the CQ12 over USB channels 13 & 14, to the “USB” input channel on the CQ12T so you can hear them. All other CQ12T channels are set to Analog input and so what you’re playing into the record track is coming from CQ12T over USB. You can monitor the live instrument from the CQ12T (before it goes to the DAW) or out of the DAW, whatever meets your need. Whichever platform you’re monitoring from, you’ll want to turn off monitoring on the other one of course.

    Sorry if I’m missing the point of the challenge you’re having, hope that helps though.

    #120589
    Profile photo of TheAngryPenguin
    TheAngryPenguin
    Participant

    I guess I will need to further explore Audio MIDI Setup, as there’s no mechanism in the Audio Device Preferences to tell the DAW to route its stereo output to a specific pair of channels.

    #120590
    Profile photo of GoodOlJoe
    GoodOlJoe
    Participant

    I’m a Windows guy and I don’t know MacOS or Reaper well enough to respond precisely, but a couple of things:

    1. In Reaper you will need to have the Audio Device set to the CQ (in your screenshot it is set to a Scarlett audio interface)

    2. The Master track in Reaper needs to be sending its output to the USB channels which the CQ routes to the “USB” input channel on the CQ. (Again, on the CQ12 that’s USB channels 13 & 14. On a CQ20 it may be 21 & 22, I don’t know for sure.) Precisely how to set the Reaper Master to output to those channels on MacOS I also don’t know. On Reaper for Windows I would set the output channels min to 13 and max to 14, which would force the Reaper Master bus to use output channels 13 and 14 as the hardware output. Very different on MacOS I’m sure but the point is: 1) find out which USB channels on the CQ20 are hardwired to the ‘USB’ input channel, then 2) do whatever is required for Reaper Master to send audio out those two channels.

    #120709
    Profile photo of TheAngryPenguin
    TheAngryPenguin
    Participant

    (screenshot borrowed for reference…) — The forum wouldn’t let me reply from where I was at on that day — it thought I was trying to spam the board.

    Anyway, thank you for pointing me in the right direction.

    #120741
    Profile photo of ruggiero95
    ruggiero95
    Participant

    Salve a tutti, ho un CQ20B e utilizzo Audition come DAW, avendo una traccia audio solo strumentale voglio registrare solo il canale microfonico come si fa? Qualcuno mi può aiutare?

    #120833
    Profile photo of TheAngryPenguin
    TheAngryPenguin
    Participant

    I have added all stereo pairs to the master out, and I am still unable to get any DAW playback through my CQ-20B. According to Channel Assignment, 23/24 is set as Main L/R (Stereo L/R). What am I missing?

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.