USB-B Muiltitrack Playback Problems – Qu24

Forums Forums Qu Forums Qu troubleshooting USB-B Muiltitrack Playback Problems – Qu24

This topic contains 18 replies, has 5 voices, and was last updated by Profile photo of Dags Dags 5 years, 8 months ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #50778
    Profile photo of Dags
    Dags
    Participant

    Hi all

    I tried searching for this problem being listed previously but couldn’t find any topics. Please point me in the right direction if I am wrong.

    I have a 48kHz, 24bit multitrack recording I made years ago that I am using as a means for testing out the desk. Similar to a virtual soundcheck, I guess.

    After much fooling around in Logic 8 to set up mono sends from the 15 audio tracks in Logic to 15 QU24 channels via USB-B, I am able to get each instrument coming in on its own Qu24 channel.
    I hit play in Logic and the song starts and the instruments all play back as expected. Cool!

    But after a minute, or even sooner sometimes, the playback starts breaking up. The best way to describe it is that a decimator or bitcrusher is being placed over the main output and slowly being cranked up until the audio just glitches out completely then stops playing altogether.

    This is what I have tried so far:
    Setting the Qu24 inputs to ‘Local’ then back to ‘USB-B’ doesn’t help.

    Turning the Qu24 off and restarting Logic works, naturally, but it doesn’t solve the problem.

    Checking digital sync – In my Audio/MIDI setup the Qu24 is the master controller by default when Qu24 is selected as the playback device. This cannot be changed, so I don’t believe that this could be the cause if the system has set this up for me.

    MTC playback synchronisation – set to continuous in Logic. I have tried other MTC options but it doesn’t fix the problem.

    Resetting the audio playback device in Logic to ‘Internal’ then back to Qu24 and letting it resync itself helps but then it happens again a little while after I start playback.

    Pulling the USB cable out and plugging it back in to let Logic relocate the device and resync to it has the same affect as playing around with the audio playback device.

    Nothing I do seems to permanently solve the problem and eventually the audio starts breaking up again.

    Has anyone else experienced this and can they help me to fix the problem?
    It is extremely frustrating!

    I tried making a recording of it into a Qu-Drive to post a sample but the resultant stereo file was blank. Don’t know what went wrong there but I’m over trying to get the desk to work properly tonight.

    It has the latest firmware V1.73 which came pre-installed as I only bought the unit home last week after it had to be ordered in from overseas.

    Any suggestions greatly appreciated.

    Thanks
    Dags

    #50779
    Profile photo of [XAP]Bob
    [XAP]Bob
    Participant

    How fat/long is the USB cable?

    The QU only operates in master mode, so that is correct.

    #50780
    Profile photo of Dags
    Dags
    Participant

    Hi Bob. The USB cable is only about 1m or so in length and is quite thick as far as USB cables go (not one of those thin, highly flexible types). I read somewhere that it cannot be longer than about 2m because of signal degradation so I made sure the one I bought isn’t too long.

    #50781
    Profile photo of [XAP]Bob
    [XAP]Bob
    Participant

    Does your DAW normally play this many tracks happily?

    #50782
    Profile photo of Dags
    Dags
    Participant

    Yep – it has handled larger sessions than this.
    There’s also no processing whatsoever on any of the channels in Logic except for the IO plugin to route the audio to the Qu24.
    I set it up as a virtual sound check session to run the Qu24 through its paces and so I can get a friend up to speed with using the desk for a festival we’ll be working at in a month.

    Edit: I should also mention that every channel has its output set to ‘off’ so that there is no chance of feedback loops occurring. The IO plugin taps the audio signal before the fader and sends the audio to the Qu24 which I am monitoring using headphones.

    #50783
    Profile photo of [XAP]Bob
    [XAP]Bob
    Participant

    Just covering the basics first – I tend to playback from a USB stick, although the desk itself interleaved files it might be worth getting a decent USB stick (Sandisk extreme) and trying it from there.

    Unfortunately that doesn’t help in terms of USB-B streaming – I’ll let others handle the subtleties there…

    #50795
    Profile photo of philt80
    philt80
    Participant

    I’ve got the same issue. QU24 as well. I’ve been chatting with tech support with no resolve. I believe it is a latency issue. I’m ready to return the board as this seems to be ongoing and non fixable. I use Studio One v3 and also Samplitude Pro x2. Both after about 5-10 mins produce a buffer underrun and the audio slowly gets to a point where I have to reboot, turn off the board and start over. I’ve rebuilt my pc, all the drivers are up to date. I’m an IT sysadmin so I have a little knowhow but nothing I’m trying works. Ive tried Win7, 8.1 and 10. I’ve tried on laptops, and desktops with enough horsepower to run anything.
    The best I can tell you is try downloading latencymon and seeing what it says. at least it will tell you what drivers are giving you the issue potentially. I’ve also tried the asio4all drivers and latencymon reports WAY less clips.
    This happens with no plugs, loads of plugs, one track, 24 tracks etc. I’ve adjusted the buffer settings till I’m blue etc. Nothing seems to work for me.

    Basically tech support has told me to adjust the latency in the driver to find a good balance. useless. nothing has worked. It has been ongoing for months. I’m pretty disappointed with A&H about this…their reputation was much better than this.
    I’ve attached a clip recorded on my phone through my monitors to send to support, also sent a video.
    Does yours sound like this?

    Attachments:
    You must be logged in to view attached files.
    #50797
    Profile photo of Andreas
    Andreas
    Moderator

    Not sure this is a A&H problem or a PC/Mac performance issue. I’ve to that running nicely on both Mac and PC using rather vintage equipment and OS (Reaper and Samplitude).
    @philt80: Are you certain to use 48kHz samplingrate on your DAW?
    @dags: Do you have your multitrack project on an internal or external drive? Your description sounds as the prefetch buffers run low as logic can’t fetch fast enough from disk. That may be a bandwith problem (external disk) or fragmentation issue (too many head movements).

    #50798
    Profile photo of philt80
    philt80
    Participant

    Hey Andreas,
    Ya. Both Studio One and Samplitude will alert if the sampling rate for a project is out of spec for the board. I’ve made sure it is always set to 48k though.
    Also this has to be a drive/asio issue as non of the other boards I have at home right now crap out like the QU24. (x32 and presonus (firewire though))
    I’ve had the projects both on 7200rpm drives and SSDs. I’ve taken the same projects from computer to computer with the same effect. I’ve also had it overrun when there aren’t even any tracks in the project.
    Not a clue!

    #50799
    Profile photo of Nicola A&H
    Nicola A&H
    Keymaster

    @dags
    Can you confirm Qu firmware version and OS X version? Early versions of Mavericks were prone to USB audio errors that sound exactly like what you are describing.

    #50802
    Profile photo of Dags
    Dags
    Participant

    Hi gang

    Phil, no my audio problem doesn’t manifest like that. What I’m experiencing is like some kind of signal degradation effect has been strapped across the main outs which builds and builds until the audio just cuts out. I’ll have another go at getting a recording of it even if it is just through my iphone placed close to the headphones I am using.

    [UPDATE – sample attached. please turn down your speakers!]

    Andres, It is a desktop tower Mac. Programs/system on one internal HD, audio projects on a second internal HD, as has been recommended since the ’90s 🙂 Both HDs are nowhere near full.

    Nicola, It is an older Mac running 10.5.8 and uses the standard Mac core audio protocol. Qu24 has the latest firmware V1.73 which came pre-installed as I only bought the unit home last week after it had to be ordered in from overseas.
    (Tried attaching a photo of the firmware screen but it is larger than the allowable 1024kb)

    Attachments:
    You must be logged in to view attached files.
    #50805
    Profile photo of Dags
    Dags
    Participant

    Nicola – smaller photo of the firmware page is now uploaded

    Attachments:
    You must be logged in to view attached files.
    #50807
    Profile photo of Dags
    Dags
    Participant

    Hmm…..I just read back over an earlier query I had and it might be that Mac OS 10.5x is too old for the Qu24 to sync with.
    Seems strange as I don’t think core audio has changed much since it was first brought introduced.

    I have been able to go the other way; recording a ‘test one two’ via USB-B into the mac for all 24 channels.
    All channels were active and recording and I simply moved the mic from input to input to check the connection. So even though there was no audible sounds on the channels that didn’t have the mic connected at the time, it was still striping 24/48 audio successfully to all 24 channels simultaneously.

    #50808
    Profile photo of Andreas
    Andreas
    Moderator

    Phew, 10.5, thought my ‘2008 Mini running 10.7 is vintage… 😉
    In fact OSX changed significantly from 10.4 to 10.6 when it comes to USB AudioClass 2 support (the part below Core Audio). And if your hardware is of a similar age, it may as well be the mainboard chipset itself, which does not provide the required bandwith.
    If streaming only IN (Device->Host) works well this may also indicate a low-level bandwidth issue.

    From a technical standpoint the USB link will always stream all channels, even if only one stream is used. While recording only one stream is required, the DAW will just pick the channels of interest.
    The opposite OUT direction (Host->Device) is slightly more complicated, since with the Qu as Clock Master the host (PC/Mac) needs to know how many samples to send in a particular time frame (1/8 mSec). The Mac simply opens the IN direction as well and sends the same quantity of samples back to the device, effectively synchronizing the understanding of samplerate on both ends.
    In this situation two streams are required, effectively doubling the USB load.

    #50810
    Profile photo of Dags
    Dags
    Participant

    Nicely answered Andreas!

    I have a 2008 Mac Pro running 10.6 as my main studio computer. I’ll patch it into that sometime this week and see if I have more success with streaming via USB-B from it to the Qu24.

    The older mac can still be used as a live gig recording device if I need more than the 18 channels that the Qu-Drive can handle.
    But it sounds like I can’t use it as a playback device.

    Pity, as I had hoped it could still be a bit more useful to me…maybe as a bookend? 😉

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.