SQ MixPad Android Compatibility Issues

Forums Forums SQ Forums SQ troubleshooting SQ MixPad Android Compatibility Issues

This topic contains 4 replies, has 4 voices, and was last updated by Profile photo of KeithJ A&H KeithJ A&H 1 month, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #112332
    Profile photo of WilliamQ

    I’m running into an issue with getting the SQ MixPad app to install on an Android tablet. It’s a Samsung Tab A SM T510. I’ve been able to use the MixPad app with my SQ5 until the latest app update of 1.5.4 from the Play Store. When I went to update the app from 1.4.0, it now says “Your device isn’t compatible with this version”. I tried to go back and sideload 1.4.0 since I knew it worked, but the install fails. I went back and did a factory reset just in case something else had messed up but I get the same messages. The only requirement listed on the Play Store is that I need Android 6.0 or higher, and I’m currently running Android 11. I bought the tablet just for remote mixing, so this is a bit frustrating that it’s no longer compatible without any warning. Is there anything I’m overlooking?

    Profile photo of IvanK

    I have the same problem also with Samsung Tab A SM-T510, Android 11. Fortunately, I have older version installed (1.5.0) that still works. On Google Play it’s not available for my device anymore.
    I just found this out after trying to install SQ4You which is also not available. What is happening?
    Please help!

    You must be logged in to view attached files.
    Profile photo of KeithJ A&H
    KeithJ A&H

    Hi both,

    The recent updates required rebuilding the apps using the latest SDK’s to support the latest OS’s.
    This has also meant that the android apps have moved to 64bit only (iOS versions have been 64bit for a while now).
    Existing V1.5.* apps can continue to be used with any V1.5.* firmware however, and the update was mainly to fix issues only seen by users of the most recent OS, only found on more recent (64bit) devices.
    i.e. there is no reason to update if you were not experiencing an issue.

    You can check whether you are running 32bit or 64bit as described here – https://www.techentice.com/how-to-check-if-android-device-is-32-bit-or-64-bit/
    A quick search for that device suggests it may have a 64bit capable processor, but runs a 32bit OS.

    If this doesn’t explain it and/or you’re still having issues, please contact us directly using support.allen-heath.com


    Profile photo of Helex

    So if I understand well, we are forced to buy new hardware!?
    The device was working well – so I don’t see why we can’t go on using the 32-bit version.
    We are a non-profit organization, strictly run by volunteers, so we don’t have hughe budgets.
    Question is: where can I download the older v1.5.x APK hich can be used with my Samsung SM-T585.

    We use this tablet dedicated for this purpose.

    Can imagine more users are going to face this problem. So please provide a download-location.


    Profile photo of KeithJ A&H
    KeithJ A&H


    No, we are not forcing anybody to buy new hardware – as mentioned, you can continue to use your existing setup.
    The only requirement as always, is that the major/feature release numbers of the app and the firmware are the same, e.g. App V1.5.0 will work with SQ Firmware V1.5.8
    To be clear though, this does mean that with any future feature firmware releases you would need to decide between getting free new SQ features and continuing to use older 32bit devices for remote control, as it will not be possible to do both.

    If you do not already have the older app installed, please contact us using support.allen-heath.com


Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.