QU 16 does not boot up

Forums Forums Qu Forums Qu troubleshooting QU 16 does not boot up

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of a&huser a&huser 1 year, 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #93809
    Profile photo of a&huser
    a&huser
    Participant

    Our church uses a QU-16 chrome edition. About a week ago, it suddenly stopped working. When we power on the unit, it powers on, but the screen is blank and every LED light on the unit (channels, EQ, pan, L&R, Mix, FX etc) comes on. Buttons and faders don’t do anything. Here are some of the troubleshooting steps we have taken but nothing worked:

    1) Tried turning it off an on again multiple times
    2) Unplugged from current outlet and plugged it into other outlets
    3) Changed the power cable
    4) Tried resetting it by pressing Reset and Set Up while powering on the unit
    5) Tried to “force install” the firmware based on suggestions on other posts on this forum by inserting a formatted USB drive and booting up the unit while pressing PFL and USB buttons.
    6) Changed the fuse with another one with the same rating

    None of the steps above did anything. Any help would be much appreciated!

    Thank you.

    #93810
    Profile photo of Mike C
    Mike C
    Participant

    Just to double check a couple things.

    To do a forced firmware update you hold down the USB and High Pass filter
    buttons while powering on.

    Was the USB stick formatted in a QU mixer? Was the firmware .QUU file in the
    root directory of the USB stick/drive only one time with no other firmware files?

    If yes to all of those it’s more than likely going to need sent in for repair.

    #93811
    Profile photo of a&huser
    a&huser
    Participant

    Yes, the USB stick was formatted in a QU mixer and yes, the .QUU file was in the root directory. After that didn’t work, we also tried a FAT32 formatted USB stick as well but that didn’t work either.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.