MIDI control from Windows program

Forums Forums Qu Forums Qu DAW integration MIDI control from Windows program

This topic contains 17 replies, has 4 voices, and was last updated by Profile photo of Mike@SCS Mike@SCS 5 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #100269
    Profile photo of Mike@SCS
    Mike@SCS
    Participant

    In my program (which runs only under Windows) I can successfully control channel mutes, etc on my QU16 using USB MIDI. However, I would also like to use Sysex messages such as ‘Get System State’, but when I try to send this message I get no response back from the QU16. Looking at the MIDI Protocol Manual I note that this is listed below info about a TCP device connection. Are these Sysex messages only available via TCP MIDI? Can I use these in a Windows environment? I’ve tried without success.

    #100271
    Profile photo of KeithJ A&H
    KeithJ A&H
    Moderator

    @mike@SCS – You are correct that there are some MIDI messages which are only available using MIDI over TCP/IP, including get system state.

    It is possible to use MIDI over TCP/IP to communicate between the Qu and Windows (or Mac), though for a stand-alone program you will need to implement active sensing as described here – https://www.allen-heath.com/media/Qu_MIDI_Protocol_V1.9.pdf#page=2&zoom=auto,-274,185

    Another option would be to make use of ‘MIDI Thru’ with A&H MIDI Control – https://www.allen-heath.com/midi-control/ – this provides a managed connection between the Qu and Windows (or Mac!) and you can then send and receive messages using the virtual MIDI ports created.

    Hope this helps!
    Keith.

    #100284
    Profile photo of Mike@SCS
    Mike@SCS
    Participant

    Thanks, Keith. I’ve just downloaded and installed A&H MIDI Control, but when I start this it just starts as a background process and I don’t get the displayed panel shown near the start of the Help document. I’m running ‘Windows 10 Home’, up-to-date, and I’ve tried uninstalling and reinstalling MIDI Control, and also rebooting the machine. I did previously have the A&H DAW Control program installed, although I never tried very hard to use it. I uninstalled the DAW Control program before installing MIDI Control. When I start MIDI Control, Task Manager shows it under Background Processes only – not under Apps.

    Is there some system setting I can apply to get MIDI Control to start properly and display the panel?

    #100285
    Profile photo of Mike@SCS
    Mike@SCS
    Participant

    I’ve just tried installing A&H MIDI Control on a different computer – an older computer with Windows 8. Same result – no panel displayed, and Task Manager just shows ‘Allen and Heath MIDI Control (32 bit)’ running as a background process. I have a network cable connecting the computer to the Qu-16, and the ‘Lnk’ light on the back of the Qu-16 is flickering.

    Could there be a setting on the Qu-16 that’s wrong?

    #100287
    Profile photo of KeithJ A&H
    KeithJ A&H
    Moderator

    @mike@SCS –

    A&H MIDI Control has been set up to run as a background task when opening as most users have it run on boot, so it would be annoying to close the Window every time and (depending on what you’re doing of course) it’s often a ‘set and forget’ kind of thing.

    The help document does show how to view and adjust the preferences, but as you must have seen these images and it wasn’t clear, there’s now an extra line of text.
    Copied here for convenience:
    “Launch Allen & Heath MIDI Control which will open and run as a background task. Right click on the icon in the system tray (Windows) or right click/control click on the icon in the menu bar (Mac) then click on Show Preferences in the menu to access the preferences panel.”

    Cheers,
    Keith.

    #100290
    Profile photo of Mike@SCS
    Mike@SCS
    Participant

    OK – thanks for that info. I’ve now set the MIDI Control settings but it’s not connecting to the Qu-16. See attached screenshot which shows MIDI Control and also the Windows Network and Sharing Centre. The ‘Unidentified network’ appears when I switch on the Qu-16 – which I did before attempting the connection. On the Qu-16 itself, the Network panel shows DHCP enabled, IP address 192.168.1.60, Subnet Mask 255.255.255.0, Gateway 192.168.1.254, and Unit Name Qu-16. Both the Apply and Cancel buttons are disabled.

    Attachments:
    You must be logged in to view attached files.
    #100292
    Profile photo of SteffenR
    SteffenR
    Participant

    how do you connect it? Direct cable?
    Or switch?

    #100293
    Profile photo of Mike@SCS
    Mike@SCS
    Participant

    Direct cable. Unfortunately I’ve only got one such cable so can’t try swapping it. However, Windows seems to recognize there’s something there when I switch on the Qu-16 as that’s when the ‘Unidentified network’ info appears.

    #100294
    Profile photo of SteffenR
    SteffenR
    Participant

    you have to disable dhcp and must configure the IP adress by hand

    no dhcp server!

    #100295
    Profile photo of Mike@SCS
    Mike@SCS
    Participant

    OK – I’ll try that soon. Having dinner at the moment!

    #100296
    Profile photo of Mike@SCS
    Mike@SCS
    Participant

    No luck with that. I disabled DHCP and pressed Apply. I left the IP address unchanged at 192.168.1.60, but MIDI Control will still not connect.

    #100297
    Profile photo of SteffenR
    SteffenR
    Participant

    and the computer? Which IP?
    you have to change this as well
    same subnet

    https://en.wikipedia.org/wiki/IP_address
    https://en.wikipedia.org/wiki/Dynamic_Host_Configuration_Protocol

    #100298
    Profile photo of Mike@SCS
    Mike@SCS
    Participant

    A&H MIDI Control also has the IP address set to 192.168.1.60, as per the screenshot I sent earlier. No subnet mask is displayed. I’ve just rebooted both the computer and the Qu-16, but no change.

    #100299
    Profile photo of SteffenR
    SteffenR
    Participant

    Are you kidding? Again, what is the IP address of your computers network connection?
    If you have a direct connection you have to configure it by hand…
    and it has to be in the same subnet as the device you connect to

    make shure that it’s different from the WiFi

    open a “cmd” window
    then type ” ipconfig /all ”

    There you can see all your IP addresses used

    #100301
    Profile photo of Mike@SCS
    Mike@SCS
    Participant

    Thanks for your assistance. I’ll check this out tomorrow. It’s after 10pm here.

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.