Couple of SQ problems

Forums Forums SQ Forums SQ troubleshooting Couple of SQ problems

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Mike C Mike C 1 week, 4 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #104468
    Profile photo of JTRJAMMER
    JTRJAMMER
    Participant

    Hello All,
    Have 2 problems. First is one of the faders has become slow to respond and mechanically move to positions as I go through the fader layers. Is there any recommended maintenance or easy replacement? Is it possible for the sticky fader to effect the level of audio on one of the channels as I move through the layers? Second problem, have the Slink option card installed and the Ethercon cable has become stuck in the connector. I can remove the cable tension and pull out the cable, but the shell remains stuck in the slot. Can I send this off for repair? would it be to retailer or to Allen & Heath?

    #104475
    Profile photo of Mike C
    Mike C
    Participant

    As for the stuck connector, on Neutrik style XLR connectors I have had about 75% success using a very small dental/jeweler pick with a to slide in around the connector and get to the release tab or a thin piece of feeler gauge material to slide on the inside
    of the barrel after you remove the connector body.

    The ones that have been stuck were mostly knock Neutrik connectors.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.