Cannot update Xone K2 drivers on Macbook Pro (2021 with M1 Pro Chip) OS Monterey

Forums Forums Other A&H products Cannot update Xone K2 drivers on Macbook Pro (2021 with M1 Pro Chip) OS Monterey

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of poweremix poweremix 1 month, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #106035
    Profile photo of CerberBG
    CerberBG
    Participant

    Hello everyone,

    I recently purchased a Macbook Pro 14 Inch with an M1 Pro processor and I tried to update the drivers for my Xone K2 controllers, but am unable to do so.
    I have 2 controllers and the software is not recognising them even tho they are 100% connected and working.
    When I first connected the first controller, I got a message in the software stating that “the bootloader cannot be started” and the update cannot be made and to try restart the software and try again. I did and nothing else happened.
    After I restarted the Macbook, I tried to update again but now the updater is not recognising that the controller is plugged in.
    I tried making the update using my second controller, but the same thing happened as above.
    When the controller is connected, I can see that it is active in the Traktor Pro 3 audio setup, therefore the computer recognises that the controller is plugged in.
    I have attached a couple of screenshots below.
    My OS version is Monterey 12.1

    If anyone knows if there is a fix for this issue, please let me know.

    Attachments:
    You must be logged in to view attached files.
    #106040
    Profile photo of CerberBG
    CerberBG
    Participant

    UPDATE: I upgraded the firmware of both controllers from 2.0 to 2.5 using my Windows PC and this fixed the issue and now I am able to use the controllers on my Macbook.

    #109607
    Profile photo of poweremix
    poweremix
    Participant

    hello my friend. i have the same macbook 14 inc. i also have xone k2, i couldn’t get it to work. do you still have the same problem. can you tell me if you solved the problem, thank you

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.