Reply To: Qu24 QDrive – No USB drive detected

Forums Forums Qu Forums Qu troubleshooting Qu24 QDrive – No USB drive detected Reply To: Qu24 QDrive – No USB drive detected

Profile photo of Corz

I had the same problem as Hanroux. Brand new desk, wanted to update to the latest firmware, got one of the A&H recommended USB sticks (SanDisk Cruzer Blade 8GB) & got the same issues eg. disk would’t format & system would just hang trying to read it. Wasted an hour or so trying different methods of getting the QU-24 to read it most of which are mentioned here. None worked. Panicked a little after reading Hanroux’s desk was faulty & needed replacing. Man my desk is brand new out of the box! How can this be? So i thought i’d try another USB stick i had laying around (Lexar 16GB) just out of curiosity to see what would happen & BANG! IT WORKED INSTANTLY!! Downloaded the latest firmware, installed it, works a charm! One thing i noticed is after the firmware installed & the desk rebooted, the LCD screen started flickering slightly. I thought here we go again…so i proceeded to shutdown & power back on & it went back to normal. Phew! All is good now & am enjoying my QU more & more everyday. My advice is ditch the SanDisk Cruzer Blade & try something else. My Lexar 16GB isn’t listed as a recommended drive but hey it works!
Hope this helps future users.