flickering mix select lights

Forums Forums Qu Forums Qu troubleshooting flickering mix select lights

This topic contains 9 replies, has 5 voices, and was last updated by Profile photo of Harm Harm 5 years, 6 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #54260
    Profile photo of Harm
    Harm
    Participant

    There seems to be something wrong with my new QU16. When starting up the desk, sometimes all Mix select lights, so LR and FX1 till Mix9-10 are on. Later on the lights start flickering in crazy patterns and are sometimes turned off. The knobs themselves do function, as pressing one of the select buttons, the screen will follow with information, concerning the button I touched.

    Who can help me. I just installed the newest firmware 1.82

    #54261
    Profile photo of Harm
    Harm
    Participant

    Here I posted the flickering lights.

    Attachments:
    You must be logged in to view attached files.
    #54270
    Profile photo of airickess
    airickess
    Participant

    I think a service call is in order.

    #54278
    Profile photo of [XAP]Bob
    [XAP]Bob
    Participant

    Yes, it’s very pretty, but not right.

    #54279
    Profile photo of Harm
    Harm
    Participant

    Can it be caused by no stable power levels in my house? That would be strange in my opinion, because it is a modern house.

    #54313
    Profile photo of airickess
    airickess
    Participant

    I very much doubt that. I think you need to take it in to get serviced.

    #54342
    Profile photo of croydon_clothears
    croydon_clothears
    Participant

    If you have installed latest firmware and it’s still faulty, then it’s a warranty issue.
    There is most certainly a fault there and if it’s new then you must get it fixed (for free) ASAP.
    Contact your reseller immediately.

    #54350
    Profile photo of David Haughton
    David Haughton
    Keymaster

    Hi @harm. Sorry to hear you’re having this issue.
    If you haven’t already, please contact A&H Product Support at support@allen-heath.com and we will be able to assist you further.
    Please also include the link to your video as this will be useful for the team to assist in diagnosis.
    Cheers.
    Harry.

    #54419
    Profile photo of Harm
    Harm
    Participant

    Thanks for your reactions. I contacted A&H and the firmware update didn’t solve the problem. So I sent the QU16 back to the retailer. They will send a new one within an few days. That will be great!

    #54535
    Profile photo of Harm
    Harm
    Participant

    Yesterday the new QU16 came in. This unit works perfectly. So problem solved.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.