Screen-Rotary fast control not working

Forums Forums SQ Forums SQ troubleshooting Screen-Rotary fast control not working

This topic contains 3 replies, has 4 voices, and was last updated by Profile photo of yd yd 2 weeks, 1 day ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #80183
    Profile photo of eotsskleet
    eotsskleet
    Participant

    On my SQ-5 the Main Screen-Rotary doesn’t work when I turn them fast – it’s more likely that the value jumps up&down just a minimum amount when i turn It fast… if I go slow – it works fine… do you think It’s a hardware issue?

    Kind regards
    Simon

    #80185
    Profile photo of Flo84
    Flo84
    Participant

    Unfortunally yes…
    I had the same issue and issue was solved by part remplacement.
    Probably cleanning (lot of grease used in the rotary have leaked on the differents cards in my case…) the rotary should work but you need to open the mixer and you have the risk to loose waranty.
    Contact your dealer is the best way…

    #81421
    Profile photo of TonmeisterDaniel
    TonmeisterDaniel
    Participant

    Hey,

    i have the same problem. I haven’t used the desk for about a month. Everything was fine until i updated the desk to the new firmware today. Now my screen rotary and the eq gain rotary have exactly the issue stated here! I have to dial in the value real slow to have an accurate behavior!

    #81806
    Profile photo of yd
    yd
    Participant

    Hi!
    I’ve got the same problème with the last firmware.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.