Random MIDI data being sent on scene recall

Forums Forums Qu Forums Qu troubleshooting Random MIDI data being sent on scene recall

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of KeithJ A&H KeithJ A&H 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #108865
    Profile photo of Dafydd
    Dafydd
    Participant

    Hi all,

    I have a Qu-16 set up in a school studio environment, connected to an iMac running GarageBand & Logic Pro X.

    Almost every time I recall most scenes on the mixer, it sends a flurry of MIDI notes to whatever DAW I have open – and, because it’s normally at full volume, it scared the living daylights out of me! This is happening with an almost-stock scene – to set it up I reset mix settings then enable channel pairing on 1-2 and switch it to USB, and that’s it.

    Does anyone have any idea why this might happen? Attached a screenshot of what the data looks like in GarageBand – I’d export it as MIDI but I don’t seem to have the option to. 🙁

    Cheers!

    Attachments:
    You must be logged in to view attached files.
    #108867
    Profile photo of Dafydd
    Dafydd
    Participant

    Update: I’m also getting note data pressing the soft keys and mute keys – this has never happened before… Anyone know how to configure this to prevent it from happening?

    #108872
    Profile photo of Mike C
    Mike C
    Participant

    I remember a work around was setting your DAW and the mixer to operate on different midi channels so they would not communicate with each other.

    #108873
    Profile photo of Dafydd
    Dafydd
    Participant

    Tried to change the MIDI channel of the mixer, Logic & GarageBand (not my personal choice, curriculum reasons) are still picking it up unfortunately.

    #108909
    Profile photo of KeithJ A&H
    KeithJ A&H
    Moderator

    Hi @Dafydd,

    The reason this happens is because you can control mixer parameters (like fader levels, mutes PEQ etc…) using MIDI.
    You can also record the MIDI being sent out of the mixer for automation purposes as well as use it to sync 3rd party system controllers.
    A scene recall changes lots of parameters and so a lot of MIDI messages will be sent.
    These messages are transmitted over USB and via TCP/IP on the network.

    The MIDI channel that you can set (in ‘Setup > Control > MIDI’) is the MIDI channel for control to and from the mixer itself and the automated (+1) channel is used for DAW Control by the MIDI channel strips on the custom layer.

    So to avoid these messages from triggering things in a DAW, you need to prevent the track in the DAW from ‘listening’ to that MIDI channel and/or the Qu MIDI device entirely.
    A quick search suggests that Garage Band lacks the ability to disconnect MIDI controllers, so you may need to achieve what you want here by removing the device from macOS using the Audio MIDI setup.

    Probably best to save a copy of the setup before you do 🙂

    Thanks,
    Keith.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.