Please help – MixWizard WZ3 Effects issue?

Forums Forums Other A&H products Please help – MixWizard WZ3 Effects issue?

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of Mike C Mike C 2 weeks, 4 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #101677
    Profile photo of kevarilla
    kevarilla
    Participant

    Hi everyone! Our church was recently given this MixWizard WZ3 16:2 mixing board, which is rad, but it looks like it has an issue, and I can’t find any mention of it around the internet – I’m hoping one of you may have the answer!

    Here’s a video of the issue: https://youtu.be/RNrMU22Btm4

    So, we noticed a faint popping sound and started to investigate. If you crank a channel/output up it gets louder. Then we noticed the popping sound happening in sync with a light in the effects section, and if you turn the effects up, the pop gets louder. If you press the SEL button to switch through the effects, nothing happens – you can’t cycle through them.

    I’ve heard the board can be “reset” by starting it up while holding the SEL button in, but this hasn’t worked (possibly because the button doesn’t respond).

    Otherwise, all the channels, etc seem to work.

    Anyone ever had to deal with this kind of issue? Is there a repair that can be done? What can I try?

    #101679
    Profile photo of Mike C
    Mike C
    Participant

    The select and bank buttons not working is not a good sign.

    Is anything other than the speaker connected to the mixer?

    Are all of the aux levels turned all the way down?

    Have you tried selecting dual or single effects mode with the recessed
    button by aux 6 on the aux masters?

    I never used it on the Mix Wizards I have worked with but with the midi connection
    and using a computer you can edit the FX settings using software you can download
    from Allen Heath. Maybe that would let you do a reset.

    #101681
    Profile photo of Mike C
    Mike C
    Participant

    I just check and the FX editing software is available here.

    Mix Wiz 3 FX editor

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.