Recording in LogicProX with 44.1kHz

Forums Forums SQ Forums SQ general discussions Recording in LogicProX with 44.1kHz

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Axel Axel 2 years, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #83099
    Profile photo of Andre S
    Andre S
    Participant

    Hi everybody,

    on last saturdays gig I tried recoding my band in LogicProX with my SQ5. It failed constantly after EXACTLY 3min and 35secs.
    I did some testing and found the following. If someone please could check my findings, that would be greatly appreciated! This is the mail I just wrote to Alex from the support team:

    I can confirm, that when I start logic at 44.1kHz (which is the default setting, I guess) the recording stops at 3min35 seconds. The error message says: storage device too slow. I find it a bit dubious that it is always supposed to be too slow after exactly 3:35, but hey: I´m not an IT expert.

    I tested the sq with 8 active inputs in logic now switched to 96kHz. It worked flawless. (I haven´t checked the audio, but the recording process didn´t stop on its own) I played played guitar through 8 Mics to have mutliple sources to record.

    Then I found something unexpected. I switched back to 44.1 …and I recording went l flawless again. That made me test some more scenarios. Result: When switch from 44.1 to 96kHz I could see for a very brief moment a message from logic: initializing core audio driver. After that I could reverted logic back to 44.1. No message poped up and I could record much longer than the magic 3:35….I checked the .wav files and they are indeed 44.1kHz/24bit audiofiled.

    Is my conclusion correct, that I can record in 44.1 (though the SQ96kHz) once the logic initializes the corresponding core audio driver? That would be good news for my project file sizes!

    Warm regards,
    André S

    #83115
    Profile photo of GregTheGrate
    GregTheGrate
    Participant

    I suspect the answer is no. SQ5, unless you have Dante, only works at 96k. Logic may be down-sampling.

    I found difficulty recording 8 tracks to Logic at 96k. It used to fail with media too slow. I changed to Reaper as the recording engine and have managed to record 16 channels easily at 96k on exactly the same computer setup – a 2012 Macbook Pro. In my experience Logic is the slow one, not the media.

    Suggest you look at Reaper. Gives you a month’s free full usage

    #83116
    Profile photo of Andre S
    Andre S
    Participant

    Hi Greg,

    thanks for your input.
    Yeah, Logic is indeed doing downsampling. Some guys on the facebook SQ group site suggested using an external SSD and reaper or Waves Tracks to record and I´m gonna try that next time I´m on the board. Recording to Logic is just me being lazy and I am used to it, too.

    I´m not sure how to do a correct sample rate conversion. I´ve read that this process is a tricky thing…

    Having the tracks in Logic with no downsampling mixready at 48kHz, so that the CPU on my MacBookPro 2010 (…) doesn´t eject the motherboard was my goal…

    #83201
    Profile photo of Axel
    Axel
    Participant

    Both,

    I experienced exactly the same problem by using a different sample size than on SQ7 (96kHz) Independent by the number of tracks you choose. Anyway, in some cases it worked for a longer recording time than 3.xx minutes, not reproduceable. We discussed this and we assume that Logic is downsampling in batches in the background using the available RAM and is than trying to save these in packages on your drive (tried different configurations including SSD) and this is where the problem occurs.

    After switching to 96kHZ I never had problems again (32 tracks).

    Reaper is also working fine. You can easily import your files into Logic from there.

    I‘m using a 2012 MacBook Pro, 16GB RAM, 1TB internal SSD.

    Best
    Axel

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.