Disable USB Midi function completely

Forums Forums Qu Forums Qu troubleshooting Disable USB Midi function completely

Tagged: , , ,

This topic contains 10 replies, has 5 voices, and was last updated by Profile photo of xyz xyz 2 years, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #62814
    Profile photo of Racktangle
    Racktangle
    Participant

    Hey Folks,

    There is a problem when working with Logic Pro X and any external MIDI Gear. My QUPac tends to go crazy and change its settings unexpectedly.

    I don’t see any possibility to exclude QuPac’s USB MIDI port in Logic. The Audio/Midi Setup App (OSX El Capitan here) is showing QuPac as a MIDI Device which cannot be removed.

    I wish there was at least a “switch” in the QuPac settings allowing me to not only change MIDI channel but to disable MIDI completely.

    A&H, could you please implement it in the next firmware update?

    Any other ideas how to solve my problem?

    Regards,
    RackTangle

    #62872
    Profile photo of Dave
    Dave
    Participant

    I had this happening on my qu-16, but i never really needed to do DAW control with the desk, where i have the QU set up in relation to my computer isn’t really effective for that anyway, so i uninstalled the AH DAW control applet from my mac and haven’t had any problems. I can see using the faders on a 16/24/32 to control faders in logic, but what are you intending to do with DAW control on the Pac?

    #62878
    Profile photo of Racktangle
    Racktangle
    Participant

    Thanks for your reply Dave!

    Well, I only tried this (out of curiosity): I installed the “AH Control App” and looked if I could control my Qu-Pac with Mainstage. It partly worked and party not (seemed like Mainstage was able to receive some data but could not send it back to Qu-Pac). Anyway, it seemed to me like I had to spend weeks to get it running (or not). So I gave it up and uninstalled the AH Control App (and one file which this App stored somewhere among the system files – I don’t remember what it was – I did it with the help of “ForkLift”).

    So, to make it more clear: I don’t want to use the MIDI functions of Qu-Pac at all.

    Even when the AH Control App is not installed (or has been uninstalled), once Qu-Pac is connected to the computer (I’m using Qu-Pac for multichannel recording and playback) it is listening to MIDI via USB. And that’s the problem. Whatever MIDI Control Command “crosses its path” is being immediately executed.

    Example:

    In my case Logic X sees these MIDI Outputs:

    Off
    All
    Virtual Midi
    V-Drums
    Roland Fantom X
    E-MU X Midi Out 2
    QU-PAC MIDI In

    If I open a MIDI file containing any MIDI CC’s I have to be very careful not to audition the file first. This would be the ultimate catastrophy and would definitely mess up Qu-Pac.
    I have to assign all the track to any outputs other than the one of Qu-Pac and even then there is a possibility that Qu-Pac fetches some unwanted data and goes crazy.

    It happened to me numerous times no matter how carefully I “tiptoed” around it.

    The best thing would be to get rid of the Qu-Pac MIDI Input all together. But how? Hmmm.

    Regards,
    RackTangle

    Attachments:
    You must be logged in to view attached files.
    #62880
    Profile photo of Andreas
    Andreas
    Moderator

    Isn’t there an option within the logic environment to not forward events to a particular port? The other direction seems to be easy to accomplish (logic not listening to midi input from a port).
    Maybe this tutorial helps: Logic Tutorial: Working Within The Environment
    But if I remember correctly, the environment is part of the project, so this configuration needs to be repeated for each project.

    #62900
    Profile photo of pt.
    pt.
    Participant

    You can do this with the Logic environment. If you open the environment go to the “Midi Instruments” layer. You’ll see a big block with nubs that shows all your physical inputs with one wire going to a block called “Sequencer Input”. To filter all Midi data comming from the Qu all you need to do is add a “Monitor” from the “New” menu. Then – here comes the finicky part – wire it to the nub that has the Qu connected. When you change e.g. the volume on the Qu you should see some data in the Monitor.
    I’ve attached a screenshot; I’ve added some additional stuff that allows me to send certain data to the sequencer, depending on what’s in the filter configuration.

    Attachments:
    You must be logged in to view attached files.
    #62903
    Profile photo of Andreas
    Andreas
    Moderator

    Well, thats the input part (Qu->Logic), what needs to be turned off is sending MIDI from Logic to Qu (Logic->Qu).

    #62904
    Profile photo of pt.
    pt.
    Participant

    Ah, misread that. If you don’t use the Qu as a destination in Logic it won’t get anything sent too is my experience…

    #64117
    Profile photo of Racktangle
    Racktangle
    Participant

    Hi Folks,

    here we go again.

    Just like I’ve said earlier, it would be great to have the whole “MIDI via USB” thing On/Off switchable.

    Right now I’m working on a project in Logic Pro X. Just 2 external MIDI devices hooked up to it. I was just trying to mute some unwanted channels on the Qu-Pac and by doing that this thing is actually sending “note on” commands to Logic and thus triggering sounds on my external synth. Wow. I’m rather not try to manipulate any volume faders etc. otherwise it would screw up some parameters I’m not even aware of.

    Am I the only one experiencing this? I’m using my Qu-Pac as an audio interface so it must be connected to my computer via USB all the time.

    #64119
    Profile photo of xyz
    xyz
    Participant

    Yes similar to the GSR
    Assignable maybe to soft keys?
    Not buried deep within TABs
    Simple Send On/off
    Receive on/off
    As per pic

    Attachments:
    You must be logged in to view attached files.
    #64121
    Profile photo of Andreas
    Andreas
    Moderator

    …disabling inside DAW would be available right now, pt described how to do it some posts above.

    #64122
    Profile photo of xyz
    xyz
    Participant

    Sorry No I’m not using Logic.
    I simply want to enable disable in/out going midi data or fader data within the QU.
    Sure you can disable that within the A & H DAW app.
    That’s way too slow for switching on/off

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.