ZED 6 power supply issue

Forums Forums Other A&H products ZED 6 power supply issue

This topic contains 39 replies, has 17 voices, and was last updated by Profile photo of bmxbandit bmxbandit 2 hours, 1 minute ago.

Viewing 15 posts - 16 through 30 (of 40 total)
  • Author
    Posts
  • #111296
    Profile photo of ANH
    ANH
    Participant

    Did you work out the ground wiring ernestoR?

    #111323
    Profile photo of ernestoR
    ernestoR
    Participant

    Yes, I did, the orange wire is GND as expected (it’s connected to several IC’s GND pins).
    It’s working well now – except for the phantom power, where I need some additional circuit; my external PSU does only provide 2x12V. But I already found a good solution from ElliotSoundProjects (https://sound-au.com/project193.htm) — BTW: a lot of well designed and explained audio projects and basic knowledge articles there!

    Thanks so far!
    Best regards
    E.

    #111324
    Profile photo of ANH
    ANH
    Participant

    Good good. Can I ask why you aren’t repairing the original power supply? It seems this would be easier and possibly cheaper.

    #111325
    Profile photo of ernestoR
    ernestoR
    Participant

    Safety risks — and I’m not sure, how reliable the original PSU is, seems to have issues for others as well. And also because of curiosity — want to play and try and learn a bit more …
    ;–)
    E.

    #111338
    Profile photo of ANH
    ANH
    Participant

    Those are all perfectly valid reasons! Let me know if you need any further assistance, and good luck with the mods 🙂

    #112169
    Profile photo of ayuptom
    ayuptom
    Participant

    I woke up today and went to my desk to work but I could not wake up my Zed6fx – for some reason the power will not come on.

    Basically when I switch it on nothing happens, no led to light up saying power is on, no signal in the monitor, nowt.

    I’ve only had this mixer 18 months, I think, if I’m not mistaken, that is out of warranty now? (outrageous in my opinion, I only left the mixer on, I wasn’t even using it, seems like a design flaw to me or built in obsolescence).

    Before I get my screwdriver out and start to unpick the mess that might be in there is there any other option for me to confirm it’s the power board or to fix it. I don’t really want to pay to fix it, why should I it was expensive enough when I bought it 🙁

    Obviously I’m not a happy chappy.
    any advice or steer to lift my mood much appreciated.

    #112170
    Profile photo of ANH
    ANH
    Participant

    I woke up today and went to my desk to work but I could not wake up my Zed6fx – for some reason the power will not come on.

    It is probably the same power supply board diode failure as the others. It would be perfectly reasonable to contact Allen and Heath and put the case to them that it’s a common premature failure and request a free repair, in my opinion. Otherwise, I’m happy to help guide you through a DIY repair if you are confident working with mains voltages and have some soldering ability.

    #112481
    Profile photo of ANH
    ANH
    Participant

    Just repaired another one of these with a dead D7 diode. This was a replacement mixer for the previous one that I’d repaired.

    #112505
    Profile photo of pedromrquez
    pedromrquez
    Participant

    Nice one ANH! Thanks for keeping the thread alive and updating us!
    Audio-Technica agreed to repair mine at no cost as it was just 2 months off warranty. But no doubt if this happens again I’ll give it a go.

    Thanks again!

    P.

    #113762
    Profile photo of Les
    Les
    Participant

    I am also having the powersupply issue!!!

    #116107
    Profile photo of Josh
    Josh
    Participant

    Hi, my ZEDi10FX recently stopped powering on. Quote for repair is unfortunately more expensive than it’s worth really! Opened it up and can’t see anything obvious, but if it’s literally just replacing a diode I’d be fairly confident with that? I’ve not worked much with electronics before though so wondering if it’d be risky. Would really appreciate some advice and guidance!
    Thanks

    #116108
    Profile photo of Pete Alcock
    Pete Alcock
    Participant

    Based on past experience of a few Zed I failures, the chances are it’s the power supply.
    Changing the power supply is very straightforward – just take the back off and a few screws. If you’ve not worked to component level on PCBs I wouldn’t attemp a pcb repair. A replacement PSU is available from A&H spares sources.

    #116111
    Profile photo of ANH
    ANH
    Participant

    Hi Josh. I have sent you a private message, let me know if you don’t get it 🙂

    #116673
    Profile photo of Smithy
    Smithy
    Participant

    Hola! Tengo el mismo problema con una ZEDi8 dejo de funcionar de un momento a otro, me podrian ayudar a resolverlo?

    #117612
    Profile photo of simi
    simi
    Participant

    Hi there,
    yes original diode was underrated. But change only this is not complete solution in this circuit.

Viewing 15 posts - 16 through 30 (of 40 total)

You must be logged in to reply to this topic.