Updated Logic Integration Tutorial?

Forums Forums Qu Forums Qu DAW integration Updated Logic Integration Tutorial?

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of robbocurry robbocurry 1 year ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #90931
    Profile photo of bagel
    bagel
    Participant

    Hello,

    I’ve got a Qu-16 and trying to set it up to work with logic both as simply a control surface and sending all sound through logic. It’s my impression the latter is easy enough, I route all the 16 channels I want, including ST1/2/3 if desired, to the logic inputs and then route them back by setting 1-16 as USB input. The hard part is trying to use Mackie Control Protocol in setting it up as also a control surface, linked with a custom later reflecting the 16 sends.

    I tried following the official YouTube tutorial but it seems like the menu options are different. I set it up as close as I could to the tutorial, but it didn’t seem to work. Until I solo’d a track in logic, setting off a crazy chain of commands to and from the board – random channels were being added to mute groups on the Qu, and in logic, every change was being undone one by one (thank god for undo history). I turned off all control surfaces in logic and figured out what all had been changed on the Qu. I’m hoping maybe there’s an updated tutorial out there? For the most part I don’t want commands like Mute group/dca assignments to the board, really just stuff like fader location, mute light etc. Any guides out there I’m missing, bc the AH youtube video isn’t doing it for me.

    #90934
    Profile photo of SteffenR
    SteffenR
    Participant

    there is a document on the support pages…
    https://www.allen-heath.com/media/DAW-Control-Help-V1.71.pdf

    #90944
    Profile photo of Alex A&H
    Alex A&H
    Keymaster

    Hi bagel,

    You may want to tune into our DAW Control live stream on Tuesday! Details here: https://www.allen-heath.com/sessions/

    Thanks!
    Alex

    #91093
    Profile photo of robbocurry
    robbocurry
    Participant

    Hi guys,
    If I’ve missed this elsewhere my apologies in advance, your help and redirection would be greatly appreciated!
    I’m a live sound guy/musician over 30 years now but haven’t really dabbled with recording very much, last time was with a Presonus desk and Studio One quite some time ago.
    The Covid lockdown has prompted me to record some stuff but not having total success with my QuPac and Logic.
    I’ve followed the guides and videos but a few thinks aren’t working. I’m very familiar with the QuPac but Logic is a different story:(
    First off, maybe these are QuPac limitations due to lack of physical faders – excuse my ignorance.

    I can get audio into Logic but no fader control reciprocation between custom layer panel and Logic faders on recording or playback.

    I’m get audio back into the QuPac on 17/18 but it sounds really mono. I’ve tried panning but I’m losing volume rather than gaining stereo.

    I’m sure there’s probably a raft of other issues but these are the things I’d love to get working!

    Any help greatly appreciated 👍🏻🙏🏻👍🏻

    #91098
    Profile photo of Alex A&H
    Alex A&H
    Keymaster

    Hi!

    I recommend watching our recent live stream for DAW Control with Qu: https://www.facebook.com/AllenHeathofficial/videos/358569658383405/

    The mono playback issue is not something I’ve come across before. Could you forward a link to a video of this behaviour to support@allen-heath.com so I can see what’s happening?

    Thanks
    Alex

    #91099
    Profile photo of SteffenR
    SteffenR
    Participant

    maybe you selected L+R as the source for 17 or 18

    #91104
    Profile photo of robbocurry
    robbocurry
    Participant

    Thanks for the replies!
    Stefan you prompted me.
    I had ch 17 & 18 linked so I unlinked the pan tab and now getting stereo once I set hard left and right on the channels:)
    The rest has yet to fall into place.
    I’m getting timeline control (start, stop req etc) now from the QuPac front panel but no link up between faders yet.
    Only seeing activity on the left hand box of the A&H DAW driver utility, somewhere there must be a midi setting that’s incorrect…
    Thanks again!

    #91111
    Profile photo of robbocurry
    robbocurry
    Participant

    Getting somewhere now!
    Got channel control both ways now, hopefully I’m on the home straight!
    One final hurdle (excuse the pun) the channels in Logic don’t correspond to the midi channels on the QuPac. Audio 1 is connected to QuPac 10 etc.
    There is some midi offset but where it is I don’t know. I’d like ch1-16 on Logic to correlate to 1-16 on the QuPac custom screen.
    Apologies again for my baby steps/ineptitude!!
    Thanks in advance for any light you can share:)

    #91123
    Profile photo of robbocurry
    robbocurry
    Participant

    All my midi connections sorted – my mistake in control surface midi allocations:)
    I have much more to learn about Logic but I’m glad to be making progress.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.