ubs to computer stopped working

Forums Forums Qu Forums Qu troubleshooting ubs to computer stopped working

This topic contains 5 replies, has 5 voices, and was last updated by Profile photo of Rick Rick 1 day, 2 hours ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #111147
    Profile photo of Red

    Hi. I hope y’all are having a good week. We have a QU-24 mixer that we got a few months ago. We have a livestream Mix on 9-10 going to MTX 1-2 which uses the USB port to output to our Livestream Windows 10 pc via USB. It’s been working for a couple months now. This past Sunday, our livestream pc stopped detecting the qu-24 mixer. Looks like the livestream pc OS patched. Thinking that might have messed up the qu-24 asio/wmd driver, I uninstalled and reinstalled it. The reinstall won’t finish because it can’t detect the usb mixer connection.

    Yesterday, I uninstalled the existing driver again and turned off the virus protection and firewall, then rebooted the pc. I turned the mixer off and back on. I unplugged and replugged the USB cable from the mixer and the pc. I redownloaded the driver. I attempted the install again but it still says the mixer has to be connected to complete the setup.

    I verified the livestream setup is still there and appears to be the same as it was before Sunday. Could I have somehow messed up the USB out to the pc? I don’t suppose you would have any ideas on what to try?

    Profile photo of Giga

    Have you tried a Mac ? Far less susceptible to driver related issues in my experience.

    Good luck !


    Profile photo of Mike C
    Mike C

    I just heard of another PC that was working perfect and now dropped the USB connection
    to the mixer.
    They have tried re installing the driver as well.

    Was there some recent windows update short of Windows 11 that some PC’s does not like?

    Settings on the mixer would not change the ability for a computer to at least see and connect to the mixer.

    Profile photo of Red

    Turns out, our 3 month old cable stopped working. We are ordering a new cable.

    Profile photo of Soundave

    My windows comp has also now stopped seeing the sq. It has been great for the last year, now, nothing. Reinstalled the sq drivers, reinstalled tracks live, swapped cable.
    Hey Allen Heath, is there a windows 11 updated driver in the works??

    Profile photo of Rick

    I wonder if this is the same issue I’m seeing, where neither my Android tablet nor any other device can detect the board. I’ve tried multiple routers, cables, and connection points, and the only thing that worked at all was hardwiring the board into an internet router, which isn’t an option at our present location.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.