TCP Midi Driver

Forums Forums GLD Forums GLD general discussions TCP Midi Driver

This topic contains 12 replies, has 2 voices, and was last updated by Profile photo of pdherring pdherring 7 years, 10 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #35268
    Profile photo of pdherring
    pdherring
    Participant

    Has anyone tried to trigger QLab from a soft key on the GLD?

    I have spent hours looking and just cant get QLab to capture a command. Or maybe I am barking completely up the wrong tree and the TCP Midi driver doesnt recieve midi it only sends.

    Thanks in advance.

    P

    #35274
    Profile photo of richardcooper22
    richardcooper22
    Participant

    I’ve done this with an iLive successfully, but not with a GLD. It’s the same driver so I’d have thought it would work. What is the midi string you are sending? Which version of QLab are you using and which licenses?

    I use the Midi Show Control Commands for GO, Seq+/-, and STOP ALL which, respectively, are;

    F0 F7 00 02 10 01 F7
    F0 F7 00 02 10 13 F7
    F0 F7 00 02 10 14 F7
    F0 F7 00 02 10 08 F7

    I do this with the buttons on a PL-10 which works superbly.

    Richard

    #35358
    Profile photo of pdherring
    pdherring
    Participant

    Richard,

    Thanks for your comments. I have made some progress, by more luck than judgment. So I am using the latest build of QLab and a pro audio license. QLab seems to do nothing with the commands you sent me when associated with a soft key. Although I know QLab is listening to the GLD because if I tell it to learn a command and then move a fader it works.

    So my question is am I being an idiot? Quite possible…. or is this a bug?

    Thanks

    P

    #35359
    Profile photo of richardcooper22
    richardcooper22
    Participant

    What Device ID do you have configured in QLab MIDI Controls preferences? The strings I’ve used above are for Device ID 0. You could use Midi Monitor on your mac to see what, if any, command is received from the soft key press?

    Richard

    #35360
    Profile photo of pdherring
    pdherring
    Participant

    Richard,

    Thanks again, So I have QLab set to use Device ID 0 as per your commands you sent, the funny thing is though that QLab wont even capture these commands or anything else I seem to put in as a custom command.

    Attached are some screen grabs from Midi Monitor, I have to admit I know squat all about midi at this level so maybe they will mean more to you.

    P

    Attachments:
    You must be logged in to view attached files.
    #35364
    Profile photo of richardcooper22
    richardcooper22
    Participant

    Ah, it does seem that the GLD might be doing something slightly odd with the command. I’ve attached what I get from an iLive which is only seen as one SysEx entry by Midi Monitor. I’ve also noted that the iLive software reformats the string when entered to be, for example, F0,F7,00,02,10,01,F7 i.e. it adds the commas. I don’t have a GLD to try it on myself but it may be worth trying. One random thing to try is to change the Device ID to 1 in QLab and the Go string to F0 F7 01 02 10 01 F7. This is just a wild idea based on a fault with another device I’ve seen before.

    Failing this I suspect there may be an issue with the GLD and how it sends custom midi strings, best raise it with A&H support.

    Richard

    Attachments:
    You must be logged in to view attached files.
    #35366
    Profile photo of richardcooper22
    richardcooper22
    Participant

    As another thought try a “Musical” midi command. I often use 9C,50,75 on the Panic all (but should work for any command) command. You’ll need to turn on Use “Musical” MIDI controls in Qlab and set the channel to 13 hit capture for the relavent command and see if it picks anything up, and then works or not.

    Richard

    #35369
    Profile photo of pdherring
    pdherring
    Participant

    Richard,

    Thanks for all your advice. Okay so it seems as you say that there is a bug using SysEx commands as custom midi commands on the GLD, yes it reformats on the GLD also to add the commas.

    By using your suggestion of the musical midi note I have now managed to get this resolved and triggering my two QLab boxes perfectly!

    Thanks so much for your help on this and guess I should log a call with A&H to get this “bug” looked into as I am sure down the road others will have the same issues I have.

    P

    #35378
    Profile photo of richardcooper22
    richardcooper22
    Participant

    Not a problem, glad to help! I’d be intrigued to hear if this is a GLD bug, I know enough about this stuff to get by, but it would be good to either confirm my thoughts or learn a bit more.

    Richard

    #35425
    Profile photo of pdherring
    pdherring
    Participant

    Ticket has been logged with A&H so lets see if they agree its a bug or if I was just being an idiot. My supplier seemed to agree it looked like a software bug.

    P

    #35685
    Profile photo of pdherring
    pdherring
    Participant

    Okay so A&H have come back to me and said the above commands are incorrect SysEx messages. They should read:

    F0 7F 00 02 10 01 F7
    F0 7F 00 02 10 13 F7
    F0 7F 00 02 10 14 F7
    F0 7F 00 02 10 08 F7

    Notice the second section is 7F not F7 as per above as F7 indicates the end of a command.

    P

    #35691
    Profile photo of richardcooper22
    richardcooper22
    Participant

    Damn it! That’s what I originally ment the strings to say, and what I use, just a typo in my post above! Oh well I obviously need to check my typing more carefully!

    Richard

    #35697
    Profile photo of pdherring
    pdherring
    Participant

    Haha no problem at all! At least we have a post here for others to find now with information on using Qlab and the TCP driver 🙂

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.