Strip LCD Crashing

Forums Forums GLD Forums GLD troubleshooting Strip LCD Crashing

This topic contains 25 replies, has 18 voices, and was last updated by Profile photo of JacobBaker JacobBaker 8 months ago.

Viewing 11 posts - 16 through 26 (of 26 total)
  • Author
    Posts
  • #67148
    Profile photo of tylermartin86
    tylermartin86
    Participant

    I’ve had this happen to me before too. I’ve also seen the strip completely fail to turn on (display and backlight off) and the display information fail to turn on, but the backlight works. As mentioned above, this could be an issue with the USB cable internally. It is rare for this to happen for me, and it always seems to happen when the console starts up. So a quick reboot fixes it for me.

    I haven’t flashed the latest firmware 1.6, but according to the release notes, there are no fixes for anything like this. It probably just is that USB cable or corrosion on the connections.

    #81103
    Profile photo of BillyP
    BillyP
    Participant

    Our GLD-112 chrome started doing this about 2 months ago.
    Always bank 2. Mostly the right-hand 4. Occasionally all 8.
    Usually have the background correct (once all 8 were black), occasionally no text blocks show on the color background, most often have correct color with character blocks lit, but no characters.
    Reboot fixes it less than 50% of the time.
    Last week, I discovered a temporary fix (works for about 20 to 30 minutes):
    1) Go to GEQ tab for any mix bus
    2) Use the GEQ fader flip button
    3) All strip LCDs light in the correct color, and get the correct band frequency label
    4) When GEQ flip is cycled back to fader function, all LCDs are lit correctly and the full designation shows
    To me this looks like a firmware/software issue, but I am not that familiar with all the internal hardware blocks.
    I have thought about the earlier post advising changing out the internal USB cables, but not sure about it.
    Is there anyone from A&H who has an idea about this?

    #81801
    Profile photo of Keith
    Keith
    Participant

    I have the same problem and am being told it is the circuit board the ribbon cable is connected to. Not the LCD, Ribbon connector, or Firmware That end is not a plug and needs to be returned to there repair center in Miss. My console is approximately 2 1/2 years old and has been babied. I’m told that circuit board alone is approximately $ 700.00. I really think there is a flaw in something here were there are so many of them going bad or having the same problem.The service tech I spoke with has acknowledged this is somewhat common. hah. Keith

    #87767
    Profile photo of Mike
    Mike
    Participant

    So 2.5 years later there’s still nothing on a fix for this? We’ve recently been experiencing the same issue and I can report the same general condition:

    I’m already on latest firmware, nothing relevant on the diagnostic tool/logs. As well as it has (as of yet) only affected the GLD-80 input banks and seemingly randomly in groups of 4 (sometimes one group, sometimes all groups, etc.).

    We have a few peripherals connected via DSnake but I don’t know those details offhand. One thought from a ‘consultant’ was a possibility that something nondeterministic in the startup sequence might somehow be throwing a wrench in things (which would account for the reboots BUT wouldn’t account for my last experience). The last major failing (2 days ago) I got it all showing correctly after a few reboots but then during use, all the screens eventually blanked out (ours have been going the no-text route as opposed to all-blocks). Nothing else seems to be impacted (all back-lighting colors, I/O control, faders, control screen, etc. works – I can also connect in via the iPad app (which was handy)). Examining the board briefly yesterday, everything was displaying normally (so I haven’t had a chance to try any of the reset tricks suggested earlier).

    Any updates from the A&H team (or anyone else with input on what they’ve done with their problem units) would be appreciated!

    #94912
    Profile photo of Vance
    Vance
    Participant

    I am also having the same issue on my GLD-112, is there any progress on this issue?

    #94925
    Profile photo of Mike
    Mike
    Participant

    Well thankfully I don’t think we’ve had many recent issues (it just sort of worked itself out I guess??) Probably not much consolation to you but maybe it’ll settle down like ours has seemed to do…

    I VAGUELY recall trying the ” When GEQ flip is cycled back to fader function,” solution above (took a bit to find how to do that if I recall) and I also don’t *think* it was a fix for me at the time, but it’s been too long ago to remember for sure :}

    #104709
    Profile photo of Kevin
    Kevin
    Participant

    I just have this problem yesterday and still happening today. Yesterday my GLD 112 Chrome got white screen issue when booting, I changed the battery then move the jumper. Then it booted up well with 0 issue.

    Later that day, in the evening I booted up my GLD then this strip LCD crashing issue happened. Tried rebooting the GLD but no luck. Tried the GEQ fader flip but no luck.
    I’ll try to open and move the jumper to previous position. I hope it’ll solve the problem.

    If there’s any real solution from A&H, that’ll bring back my trust with the brand.

    #104710
    Profile photo of Kevin
    Kevin
    Participant

    UPDATE
    No luck at all. Moved the jumper and it goes to white screen issue again. Keep rebooting it and still no luck.
    The color can be changed correctly though, but the text still crash

    #104712
    Profile photo of Scott
    Scott
    Participant

    Try removing cleaning, and re-seating the USB cables. They are what drive the channels strips. Some contact cleaner should do the trick.

    #104716
    Profile photo of Mike C
    Mike C
    Participant

    In addition to the internal USB cables clean and re-seat the ribbon cables.

    Also check the contacts on the battery holder.

    #104942
    Profile photo of JacobBaker
    JacobBaker
    Participant

    Necroposting is real, doubt the dude has been waiting 4 years for the answer

Viewing 11 posts - 16 through 26 (of 26 total)

You must be logged in to reply to this topic.