SQ6 FADER FAILURE

Forums Forums SQ Forums SQ troubleshooting SQ6 FADER FAILURE

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of TK TK 5 months, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #117727
    Profile photo of TK
    TK
    Participant

    Hi, i am from Abuja, Nigeria and presently in charge of our local church media department. We got an SQ6 console sometime in 2022. In less than 6months we started getting Fader failure when powering up and we had to keep doing a hard reset anytime this happens. Later it stopped and it only happened a few times this year but in the past 1 month it has been frequently giving us this failure.

    Basically when we power up, the faders do not move or respond, then we updated the firmware to 1.5.7 and it starts working after the update and restart but coming the next day to power up it still gives us the same failure.
    Please i need support on what might be responsible so the church will take necessary steps.

    #117737
    Profile photo of Brian
    Brian
    Participant

    You need to reach out to your country’s distributor (https://www.allen-heath.com/community/distributors/) to see about getting the problem corrected. It sounds like a hardware failure, but they should be able to help diagnose the problem too.

    #117738
    Profile photo of TK
    TK
    Participant

    Thank you, I just contacted them. i will update when eventually fixed.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.