SQ Drive multitrack recording

Forums Forums SQ Forums SQ troubleshooting SQ Drive multitrack recording

This topic contains 14 replies, has 9 voices, and was last updated by Profile photo of Alex A&H Alex A&H 6 days ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #87652
    Profile photo of Mark
    Mark
    Participant

    We have an SQ6 running firmware 1.4.3 (I think it’s .3).
    I experience a high number of errors when recording multitrack to a San Disk Ultra USB 3.0 32GB drive that is shown to work in your online database.
    https://docs.google.com/spreadsheets/u/2/d/e/2PACX-1vSRGk-ihkEh_jdzODLd6bPr8Lwhu-bpMtXEnyHU_EysBZeW2Qc_GjP-yt5p6p-DiIhINqsMKp44nNHJ/pubhtml?gid=1526078633&single=true

    This feature was not the only one that lead me to choose this mixer over others, but it was an important one.

    Does the amount of processing we are running (FX, PEQ, Compressors) have any effect on USB recording error rates? What about the number of channels
    in use? Or if we are using tie lines or direct outs for routing to the USB SQ drive? There must be different scenarios that have an effect on this problem.
    Some users sail on without trouble and others can’t make it work with drives known to others to be ok.

    Has Allen & Heath tested any USB pen drive on the SQ and found one they recommend yet? Surely if you are advertising this feature,
    you have successfully made error free recordings on at least one model of USB drive. Could you let us know what at least one
    of these models is? Would you sell us one through your dealer network?

    I referred to the database below to choose a pen drive and it didn’t work for me:
    https://docs.google.com/spreadsheets/u/2/d/e/2PACX-1vSRGk-ihkEh_jdzODLd6bPr8Lwhu-bpMtXEnyHU_EysBZeW2Qc_GjP-yt5p6p-DiIhINqsMKp44nNHJ/pubhtml?gid=1526078633&single=true

    I chose the Sandisk Ultra USB 3.0 32Gb since a user made a recording over an hour without troubles. I didn’t have the same joy. I see several USB pen drives tested by A&H for the QU desk, but I don’t see any that A&H has tested for the SQ desks. Note that I have no trouble making a stereo recording or saving shows to a USB. And I can make multitrack recordings, they are just full of errors. I have formatted the drives both in a PC (FAT32) and in the SQ. For me, it is not a problem of the SQ reckognizing the drive or refusing to format it.

    Since I was not successful by choosing a drive from the devices listed by users, I am reluctant to spend $60+ for a USB HDD without knowing for certain it will work.

    On your Youtube channel, you have a video describing the ability to record stereo or multitrack to USB pen drive or USB hard drive.
    https://www.youtube.com/watch?v=d0lYSty1uLY. At 0:27, an aluminum bodied USB drive is shown in the USB port on the surface of an SQ mixer.

    Attachments:
    You must be logged in to view attached files.
    #87662
    Profile photo of Mark
    Mark
    Participant

    I spent some time working on this issue tonight and saw some interesting behavior.

    I had formatted a Sandisk Ultra USB 3.0 32GB thumb drive at home on a Windows PC. That model USB drive is one that is shown to work on the A&G database that has been derived partly from user provided info. On the first try, the “Record Load” indicator would gradually rise to the max, the error counter would increment by 1, the USB drive light would blink off and then stay on for about 10 seconds. This happened very regularly at about 10 seconds per error.

    So I formatted the USB thumb drive with the SQ mixer. No joy on the first recording attempt. It produced the same regular error every 10 seconds. I looked at the IO screen to see if I could just use the two channels that I was using to play music from my phone and possibly reduce the load going to the USB drive. I know SQ drive saves all 16 files anyway, but I was reaching for a fix. Through the I/O screen, I cut out all of the local mic ports going to the SQ drive and just left Main L/R (USB 1/2) and the stereo input jack I was connected to (routed to USB 15/16). Bingo! It recorded for over a minute onto the same USB drive with no errors and the “record load” indicator never passed about 50%. This produced the 2nd track on the drive. So I returned to the IO screen to setup the routing I really needed. That included 14 local ports XLR and I left 15-16 channels into the SQ drive coming from the stereo 3 jack I was connected to on the phone, normally probably will not need to record from a phone to USB 15/16. That went back to producing errors at 10 seconds.

    So started removing tie lines from the IO screen. First one at at time, then all of the rest except for stereo 3 going to USB channels 15 and 16 like I had setup when it worked correctly. Still no joy. There’s more going on here than just the model of the USB stick that is used. I reformatted it again with the SQ and still no joy.

    Keep in mind that I saw it work just fine at one point tonight…on the same USB drive and it had been formatted by the SQ board both when it worked and when it didn’t. For the instance when it did work, it had not been formatted after the failed recording before. It had no other data sent to it between the failed recording and the good one. It had not been out of the drive either. I did not save any other data to it (like shows, scenes, librarys, stereo recordings, etc.) in between the good and bad recordings.

    #87663
    Profile photo of Mfk0815
    Mfk0815
    Participant

    For me the SQ drive was never reliable enough to use it. Too much possible issues with the USB drives. And 16 Channels are in 90% of my use cases too less. Now I use the SQ drive just during the installation phase with some stereo WAV files to test and adjust the FOH and monitor system.
    For recording I go the route with a laptop and Reaper as DAW, either via USB B or, since I own a Dante card, with that card. Ok, there were some issues with USB B too in the very beginning but since V1.2 i had no problems with it.

    #87670
    Profile photo of Barryjam
    Barryjam
    Participant

    If I recall correctly, as early as QU, A&H got to the point of saying that hard drives (especially SSD) might be required for direct drive multitrack recording.

    I understand that you wouldn’t want to spend extra money on an SSD. As a practical matter, I always end up needing something like an SSD anyway, for long term storage of these huge multitrack files.

    #87674
    Profile photo of Mark
    Mark
    Participant

    First, I was wrong and our firmware was 1.4.1. I updated it to 1.4.3 today and didn’t see any change and didn’t expect to since multitrack USB is not mentioned in the release notes.

    My intended use of multitrack recording was to run virtual soundcheck for mixing practice. Coming from our church’s 15-20 year old analong mixer, I had very little experience dialing in a compressor and none using a 4 band PEQ on individual inputs. So being able to run a virtual sound check without the musicians to practice mixing and configuring EQ, compressor, and probably some reverb was going to be a big help. The A&H website still has text that says multitrack recording to a USB “key” is a feature. And the Allen & Heath YouTube channel still has a video that shows a USB “key” being used for multitrack.

    Quoted from the SQ page on the A&H website: “Flexible multitrack recording
    The integrated SQ-Drive makes it quick and easy to capture a 96kHz multitrack or stereo recording of the show direct to a USB key or drive. No software setup, no soundcard driver issues and no extra laptop to bring to the performance. SQ-Drive is also a smart way to manage walk-in music.”

    What happened between the production of the website and youtube video that has moved us from it being a feature to now being “not recommended”? A&H has a good reputation and probably didn’t promote this feature without knowing it worked. If it works for them, I wish they would sell us a USB stick as an accessory. We purchased our mixer through Sweetwater and my rep has been super responsive and A&H responded to his inquiry quickly too. I just didn’t get an answer I was really hoping for.

    The screen shot I attached to my initial post is from the SQ6 video on SQ drive and it’s shown being inserted along with directions to setup SQ drive for stereo and multitrack recording.

    Perhaps a future firmware update could allow recording fewer tracks which wouldn’t be such a load on the USB port/drive.

    I have been considering another external USB drive for storage of photography RAW files, but advice from A&H is the drive you use for SQ drive should not be used for other uses, even saving shows, scenes, etc. We purchased the mixer through Sweetwater and my rep has been super responsive and A&H responded to his inquiry quickly too.

    Today I tried some routing changes hoping to at least see some change in the error rate but I didn’t. However, I had one recording where it ran 01:23 with only 3 errors. I stopped the recording. Then restarted it again and it went back to producing an error about every 10 seconds. Same drive, same format, and it never even came out of the USB port. No changes were made in routing, mutes, processing, etc. That makes no sense to me. I can’t see how either the mixer or the usb drive would cause that.

    In all my attempts this morning, I found that if you delete the various folders on the drive, the SQ will replace them just by inserting the drive into the port, even without formatting. After formatting one time, the mixer said the drive was “in use” by stereo recording. Of course it wasn’t or I could not have started the format. I removed the drive and reinserted it and it reported ready.

    I have tried a Sandisk USB 3.1 drive that is smoking fast in a PC. It’s rated at 150 MB per second write, but that’s at USB 3.0. No telling what how fast or slow it is at USB 2.0 if that’s anything like the standard the SQ is using.

    Earlier I wrote that I had one recording for about a minute that worked fine. That may not have been true. I did see one today where the recording load was *almost* always about 30%. But occasionally it would hit the limit and increment the error counter. I may not have noticed that way back, so that earlier claim I made might or might not be right.

    I guess I’ll give in and order the external HDD that my rep recommended after he emailed a time or two with A&H.

    And if you are reading this thinking about buying an SQ, I still really like everything else about it. It’s super easy to get around on and everything else works and sounds great. And that’s especially true for the things you need to access during a performance. Some setup things aren’t so obvious where they are, but when you see what they did, it makes perfect sense.

    #87676
    Profile photo of Mfk0815
    Mfk0815
    Participant

    I think that A&H tells you that „if you finally find a working USB device you can use it for multitrack recording using SQ drive“. For me there to much possible problems and so I go the reliable route as described above. Ok, there is a extra laptop needed and a DAW software (Waves tracks live works too and it‘s free). But that is, for me, acceptable because now I don‘t have to worry about whether it works or not.
    Of course it is up to you to test again and again to find one device which works for you. I personally have not that time and I also do not want to buy different devices until I find a suitable one.
    BTW as far asI know you should use USB 2 devices rather than USB 3. don‘t ask me why but the A&H mixers seems to work better with USB 2 devices.

    #87680
    Profile photo of Søren Steinmetz
    Søren Steinmetz
    Participant

    I simply use a Samsung EVO850 SSD Drive in an external USB enclosure, yet to fail me and I have lots of space for recordings if needed.

    #87686
    Profile photo of volounteer
    volounteer
    Participant

    @mfk0815

    USB 3 Drives all failed on our Qu

    The only drive that let us back the thing up was a usb 2

    Maybe the SQ is really that different from Qu but still
    none of my other electronics has any issues with usb drives
    so why does AH have such problems?

    AH should sell guaranteed to work usb devices if there is such a problem finding one that will work

    #87697
    Profile photo of ianhind
    ianhind
    Participant

    I’ve been using the Samsung T5 SSD (500GB) without any issues, been very reliable and cost effective!

    #87798
    Profile photo of Mark
    Mark
    Participant

    Update with success.

    I made three error free multitrack recordings on a Sandisk Cruzer Glide 16GB USB drive that had previously failed for me. But this time, I had formatted it differently in a windows 10 PC. During formatting on the PC, I specified a “Allocation Unit Size” of 32 kilobytes. I still used the FAT32 filesystem. I think 32GB is the largest drive that FAT32 can be natively used on, so this may not work on drivers over 32GB. The total time of the 3 recordings I made was around 45 minutes. The “recording load” indicator always stayed below the red.

    Note that this same drive is shown by several other users to not be compatible with either the QU or SQ desks on the A&H drive listing at:
    https://docs.google.com/spreadsheets/u/2/d/e/2PACX-1vSRGk-ihkEh_jdzODLd6bPr8Lwhu-bpMtXEnyHU_EysBZeW2Qc_GjP-yt5p6p-DiIhINqsMKp44nNHJ/pubhtml?gid=1526078633&single=true

    But it worked fine for me after reformatting as shown above. After formatting, the SQ6 (running 1.4.3 firmware) said the drive needed formatting. So I let the SQ format it but I expected that would overwrite the allocation unit size that I had set when formatting the drive on my PC. To my surprise it didn’t. With so much inconsistency involved in using USB flash drives on the SQ, I can’t for certain say that formatting with FAT32 / Allocation unit size of 32 kilobytes is the solution. But it worked for me and on a drive that was previously not working for multitrack recording on the SQ.

    #87917
    Profile photo of Mark
    Mark
    Participant

    Update #2

    I had another Sandisk Cruzer Glide 16GB USB flash drive (USB 2.0). It probably came out of the same package as the one in my last post. It has the same item number on the back but this one produced errors every 5 seconds. There’s no telling how many ways I have tried to format though so that may be the difference.

    Since then, I received a Samsung USB 3.1 Flash drive BAR plus as another use recommended on another thread. It works great for multitrack recording. I took it out of the package and straight into the SQ6 USB slot. The SQ complained that it needed formatting, so I let the SQ format it. After the indicator displayed 100%, a message came back that it was “in use”. I pulled it out of the slot, waited a second, and reinserted it. Occasionally, it will produce one error about 4-5 seconds into the recording. But after that initial error, it runs error free.

    #87936
    Profile photo of Stonepiano
    Stonepiano
    Participant

    Hi,

    I have a brand new Seagate 500Gt SSD- drive, it refuses to arm multitrack recording. No such issue with a 3.0 thumb drive. (although it wasn´t fast enough, files were broken)
    The drive has been correctly formatted for SQ, any ideas why multitrack “arm”- button is greyed out?

    #87945
    Profile photo of Stonepiano
    Stonepiano
    Participant

    Well… the issue miraculously solved itself. When I connected the drive again, it works as intended. Strangely, this happened after registering the console, but I suppose that should have nothing to do with USB-functionality?

    #87978
    Profile photo of Finck
    Finck
    Participant

    I have owned an SQ5 for over 1.5 years and have been unable to successfully record in multitrack.
    I have bought and tried about 5 HHD.
    On a few gigs I got it to record multitrack a set (1hour), but not the second set.
    I am very disappointed.
    I need a reliable way to record 16-tracks throughout the entire gig, typically (Qty-3) 1-hour sets.
    Can anyone recommend a solution?
    P.S. Last night my “soft knob” would not advance “scenes”, unless I turned the knob very slowly.
    When I reached scene 250, I discovered that all of the previously stored “I/O” routing for that scene was lost/gone.
    WhAt is going on with this console?

    #87987
    Profile photo of Alex A&H
    Alex A&H
    Keymaster

    Hi Finck,

    I’m sorry to hear you’re having trouble with your SQ.

    I recommend starting a ticket at support.allen-heath.com so that we can go through each problem you’re seeing in more detail.

    Thanks
    Alex

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.