Right Touch Screen Not Working

Forums Forums Avantis Forums Avantis troubleshooting Right Touch Screen Not Working

Tagged: 

This topic contains 6 replies, has 6 voices, and was last updated by Profile photo of Enuncia Enuncia 3 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #111713
    Profile photo of Joe
    Joe
    Participant

    The right screen on my recently acquired Avantis isnt registering touch. The screen updates when I flip through layers and there doesnt appear to be any damage. Are there any steps that I can take to fix this or should I just be sending it back.

    #111726
    Profile photo of Andrew
    Andrew
    Participant

    The same thing has happened to our Avantis as well. We’ve had it for only a couple months, but about 2 weeks ago the right touchscreen stopped registering touch. Everything displays properly and all the sliders and layers work just fine, but we can’t interact with the screen with touch.

    The board hasn’t moved since we first set it up, and is typically only used 2-3 times per week.

    #111729
    Profile photo of Andrew
    Andrew
    Participant

    Update:

    After reading suggestions elsewhere I reset the network settings (and also unplugged the Ethernet cable) then restarted the board. The touch screen started working again when the board powered back on.

    Not sure how those systems are linked, but thought I’d share what worked for us.

    #112711
    Profile photo of Charles
    Charles
    Participant

    This forum is a godsend. We’ve only had our Avantis for 3 days, and I’ve experienced this twice now. If I haven’t seen this article, I would be freaking out.

    Currently, the successful routine seems to be:

    • Unplug network
    • Unplug Slink
    • Wait 15 seconds
    • Plug in network
    • Plug in slink
    • Setup, Config, Network, Reset, Yes
    • Utility, Power Down, yes
    • When safe, cut power using switch in back of console
    • Wait 30 seconds
    • Power console back on
    • Right screen working again

    The entire sequence takes a couple minutes to complete, primarily due to boot and shutdown times.

    I will update here if ever the above steps don’t solve the issue, which seems intermittent. Works flawlessly across a few boot cycles, then the issue comes back. At least, that’s been my experience for all of three days.

    #113056
    Profile photo of SteffenR
    SteffenR
    Participant

    Since the systems are networked to share the control data on all components, there could likely be something that disturbs the control network so that the controller on the rights screen could malfunction.

    Just a guess…

    #114151
    Profile photo of CalebMobile
    CalebMobile
    Participant

    I am having the same problem. The process of restarting the unplugging the network cable, resetting the network settings works every time but i was curious if anyone has found a permanent fix?

    #116431
    Profile photo of Enuncia
    Enuncia
    Participant

    Hey y’all, now having the same problem, but the fixes above are not working. I’ve reset the network/S-Link connections, the network settings, power cycled, etc. Nothing works. I also tried doing a factory reset, and when that didn’t work re-updated the firmware, which also didn’t fix it. I did randomly get it to start working again the other night when I connected an iPad to it so I could make a stand-in right screen, but that’s not fixing it tonight, so it may have just been coincidence last time.
    Anyone have any suggestions for what to try now?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.