QU-drive stereo playback digital splat at end of file

Forums Forums Qu Forums Qu troubleshooting QU-drive stereo playback digital splat at end of file

This topic contains 35 replies, has 10 voices, and was last updated by Profile photo of Dick Rees Dick Rees 4 years, 4 months ago.

Viewing 15 posts - 1 through 15 (of 36 total)
  • Author
    Posts
  • #61749
    Profile photo of MattFog
    MattFog
    Participant

    At the end of a stereo file playback using QU-drive, I get a full range digital distortion. I’ve tried about half a dozen USB drives – results vary, but distortion occurs most of the time. I’ve also tried a range of bit-depth and sample rate combinations – again results vary, but distortion occurs most times. I’ve demonstrated the problem to my local dealer and we replicated the fault on another QU-24 mixer, using both my USB drives and also on a drive he had with audio files he supplied. The distortion ONLY occurs at the end of a file. Anyone else experienced this issue – anyone got a solution?

    #61754
    Profile photo of AlanG
    AlanG
    Participant

    Sounds like the file on Qu_Drive has not been closed properly. Try shutting down the QU_24 fully before removing the QU_drive & then re-playing the recording on a Win Media player on a PC. If it then works OK that proves that it is.

    I don’t know how you fix it on the QU_24 though – sounds like a code bug.

    AlanG

    #61765
    Profile photo of MattFog
    MattFog
    Participant

    Thanks AlanG, the files I have been testing have all been created somewhere other than by the QU-24. Mostly in a DAW (Soundscape and Cubase). We have tried downloaded files and files extracted from CD’s too. I really only need the QU-24 to play back the files – we’re using it for performance, so it’s a feature I’d really like to have working properly. At this stage, I’m just adding 3 minutes of silence to the end of each file I create so that it never gets to the end of the file (and goes “splat” through the PA). The recording side of the QU-24 is fine, both to QU-Drive and USB streaming – no problems at all.

    Matthew

    #61829
    Profile photo of Huxby
    Huxby
    Participant

    I have just bought a QU-16 and need to play stereo backing tracks from the Qu-Drive and came across this problem straight away – loud digital splats at the end of every file. However, I have found a solution. The problem is caused by files which have an incomplete frame at the end of the file. My files are 44.1kHz and these comprise 75 frames per second of 588 samples. If I produce files that are a whole number of frames, then these do not splat at the end. How you achieve this is down to your DAW. I used Adobe Audition (CS5.5) to produce the files. To use this to trim files to an exact number of whole frames, select View/Time Display/Compact Disc 75fps. Then select Edit/Snapping/Snap to Frames, then use your cursor to highlight all the audio with the exception of the remaining part frame at the end and select Edit/Crop and save the resultant file. This should fix the problem in the short term, but hopefully Allen & Heath will sort this out in the next firmware upgrade.

    #61838
    Profile photo of Andreas
    Andreas
    Moderator

    Strange finding, since WAV files have no such framing at all. They store audio as a stream of audio clusters (6 bytes for stereo with 24 Bits). It still may relate to some sort of buffering or alignment issue, since file data always is read in multiples of sectors of 512 bytes each.
    Does this happen with Qu-recorded stereo files as well?

    #61840
    Profile photo of Huxby
    Huxby
    Participant

    I admit it is an odd finding because, as you say, WAV files themselves had no such limitation. I know this problem from years of CD production, especially when mastering discs with continuous audio across track boundaries. CD audio tracks are always a complete number of frames so ripped CD audio tracks should not splat when played on the Qu-Drive. Quite why the Qu-Drive should be affected by this issue is beyond me, but my tests do bear this out. I only took delivery of the Qu-16 4 days ago and am now too busy to look into it further. I have tried replaying a stereo file which was recorded on the Qu-Drive and, interestingly, this was not affected. However this file is a 48kHz recording so maybe it is something to do with the way the Qu-Drive converts the sample rate. As I say – if only I had more time!…

    #61841
    Profile photo of Huxby
    Huxby
    Participant

    In fact I have just converted all my WAV files to 48kHz and the problem has gone away. Simples. Obviously an SRC problem. There are still occasional small “ticks” at the beginning and end of files though. Hopefully if A&H put in some soft muting, this will go away too.

    #61859
    Profile photo of MattFog
    MattFog
    Participant

    Huxby – Thanks for the suggestions. I changed my DAWs view to “seconds” and tried a exporting a few mixdowns (48k/24bit) with a range snapped to full seconds (I can work with full seconds for my playback files and I assume it fits with your guidelines). So far no splats – I’ll keep trying – it’s looking good 🙂 I’ll try some other bit depth/sample rate combinations.
    Andreas – I tried recording some stereo files using QU-drive and they played back fine on my QU-24. Unfortunately this doesn’t help me as I have to play back files I’ve created in a DAW.

    #61861
    Profile photo of airickess
    airickess
    Participant

    Just make sure all of your files are 48kHz 24-bit for playback on the Qu.

    #61864
    Profile photo of Lee7
    Lee7
    Participant

    I experience the same problem with my QU-16.

    We use a short intro for the band that I start upon walking to the stage and let it run until the end before the band starts up. Every time it finishes there is this audible distortion or what sounds a bit like the olds days when searching for channels on your TV when between signals.

    I have played the file back on my PC to see if there has been something left behind which I haven’t removed, nothing at all. So seems to be a common fault across the board with the QU models.

    So what I do now, as soon as the voiceover has finished I turn the volume down on the channel as I have a second or two to be able to do this before I crack open with the guitar.

    The audio playback is probably the worst part or one for a better word, the most limiting part of the desk. Isn’t the end of the world as I can still play the intro over Apple Airplay which works well.

    🙂

    #61866
    Profile photo of MattFog
    MattFog
    Participant

    Airickess – Page 53 of the latest QU mixer reference manual states that WAV files of 44.1 or 48kHz, 16 or 24-bit, can be used for replay. I have been getting splats on files at 48kHz 24-bit in any case, so in my own experience that’s not the cause or the solution.

    #61888
    Profile photo of MattFog
    MattFog
    Participant

    I’ve tried a little more testing to see if the suggestion made by Huxby might work for me. I made the following stereo broadcast WAV files in my Soundscape DAW. They were snapped to full seconds in length. My DAW confirmed the duration to be in full seconds. (I was unable to set my DAW to 75 frames per second, so I hope that files of full second length would suffice.)

    16/44.1
    16/48
    24/44.1
    24/48

    I then made up the same configuration of files but NOT in full seconds, (I turned the snap off and made sure I was not creating files of full second length. I numbered the set of eight files 1 to 8.

    I then formatted three different types of USB drives in my QU-24 and copied the eight files into the play folder of each one. I set my QU to “repeat all”, and wrote 1 to 8 on a bit of paper and put a tick or a cross after each file had played, depending on whether or not it had caused a “splat”. I went around the cycle of eight on each drive about 4 or 5 times.

    The results were completely consistent each cycle – ticks and crosses going in the same spot each time around – SO IT’S NOT RANDOM. Each drive however had it’s on unique response to the cycle of eight files. So it IS drive dependent. There was not one single file which passed the test on all three drives!

    One drive liked three files, another drive liked two, and the third liked only one of the eight – a very poor result indeed and it would appear that files of full second duration are not the answer.

    So at this stage I am still without a solution and as the “fault” was replicated by another QU-24 at the dealers shop when I dragged my unit in for comparative testing some months ago and others have indicated the same experiences here, I can scarcely believe that this is not a “known fault” and documented as such, somewhere. My dealer was mystified, the sales rep didn’t have an answer, the regional manager was informed (I believe) and I’m posting here, but still no solution (or at least an explanation) from A&H, which I feel the QU users are entitled to.

    Matthew

    #61929
    Profile photo of robbocurry
    robbocurry
    Participant

    I’ve literally converted 100s of files, for backing tracks and break music, via iTunes “convert to WAV” and never experienced this problem.
    I’m converting them to 48khz (need to check bit depth) and they also work on another brand digital desk too.
    I always use the “play single” track option on the qu-drive FYI.
    I initially used other DAW software with mixed results (regarding files being recognised/visible) but the iTunes method worked so well it’s my default method now.
    I’m using various pen drives, not all able to support multitrack recording so they’re not exclusively ultra fast.

    #61950
    Profile photo of Andreas
    Andreas
    Moderator

    Well, WAV is not WAV, particularly if it comes to data alignment. I saw DAWs which insert larger dummy chunks just to let the wave data start at an exact sector boundary and fills up these chunks to be a multiple of 512 Bytes.
    WAV does not think in seconds or frames and also filesize is irrelevant, if data needs to be sector aligned internally for proper playback (would be bad if that’s the case).
    Maybe Soundscape adds some “private” data which isn’t correctly interpreted by the Qu.

    #62027
    Profile photo of MattFog
    MattFog
    Participant

    robbocurry: thanks for the suggestions. I don’t use iTunes and would prefer not to, so I’ll keep that option on hold unless all else fails. It would seem a shame to have to add the extra step of “convert to WAV” when I am the creator of the files and I can make them in my DAWs to whatever specification is required (other than in chunks of 512 bytes, or so it would seem). I’m not using any kind of ripped files – in other words, I’m not using content that others have created.
    I too use “play single” as I need to fire each item manually, however it doesn’t seem to change the outcome of the “splat” issue whatever play option I choose.
    I have tried a selection of different drives which DID produce different “splat” outcomes – I think that’s a very interesting twist in the plot.

Viewing 15 posts - 1 through 15 (of 36 total)

You must be logged in to reply to this topic.