QU CC# FOR THE MIDI LED FOR CUSTOM LAYER

Forums Forums Qu Forums Qu DAW integration QU CC# FOR THE MIDI LED FOR CUSTOM LAYER

This topic contains 8 replies, has 2 voices, and was last updated by Profile photo of Andreas Andreas 5 years, 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #53323
    Profile photo of neptoon
    neptoon
    Participant

    So I have DAW control set up on windows pc VIA a generic template I created in Cubase 8.5. Everything seems to work great. I have the following working:

    Fader + Fader Automation Receive and Transmit
    Mute On And Off
    Channel Select
    SOLO set using the PAFL button.

    My Problem is here. I set a transmit out to the mute to try to get the LED’s to respond when a channel is muted etc, And well cubase sent the message but now the mute light won’t go off no matter what I do. Are the MUTE LED’s on another MIDI CHANNEL? Or maybe controller number? I tried to read the MIDI PROTOCOL manual but I’m still trying to wrap my head around it. Going to decipher all the HEX later. LOL Anyone have any ideas on this?

    #53324
    Profile photo of Andreas
    Andreas
    Moderator

    What exact message do you see?
    From the Qu MIDI Spec it should be two Note events. If your console configured on lowest MIDI channel and you want to control channel 2 I’d expect something like:
    Mute OFF: 90 01 3F 90 01 00
    Mute ON: 90 01 7F 90 01 00
    If you’re able to turn Mute ON but not OFF, I guess the velocity of the first note event is zero resp. not between 01..3F (1..63).

    #53325
    Profile photo of neptoon
    neptoon
    Participant

    Well I’ve got the mutes working correctly. It’s the MUTE LED lights I was having the issue with. I sent a transmit back to the board from the mute key and basically what happened was I hit Mute, It muted the channel. The red mute light came on as I was hoping it would, But the problem is on the unmute. Which it unmutes the channel just find. The board just isn’t receiving a transmission from the DAW to turn the LED LIGHT OFF. So it just stays on. After that happened I couldn’t turn on the red light. I had to basically do a hard shutdown so it wouldn’t SAVE the mix with the LED LIGHTS on. Make more sense? basically mute works perfectly. It’s just the LED LIGHTS that are giving the problem. once the DAW turns them on I can’t turn them off.

    #53326
    Profile photo of Andreas
    Andreas
    Moderator

    Well, that way it more sounds like a firmware issue. Don’t think that Mute function and Mute Led are intended to be controlled independantly. Do you have the MIDI messages sent to the Desk? Sure that would help.

    #53327
    Profile photo of neptoon
    neptoon
    Participant

    I am one firmware behind, I’ll load up the latest and see if that fixes it. And yes I did. Same way I have the faders set to to receive the transmit from my DAW. That being Cubase Pro 8.5. It’s weird the first time I hit it the light pops on, But after that no matter if I mute unmute it’s always on from that point forward. LOL. again I just do a hard shutdown so the mixer doesn’t save the settings. Ok will try that update and see what happens. BBIAB to give you the outcome.

    #53335
    Profile photo of neptoon
    neptoon
    Participant

    So updated the firmware with no success on getting this issue resolved. And what it does is when I hit mute in cubase it transmits to the mute on the mixer and turns the light on , But again can’t get it to go off once the light comes on during the first go around.

    #53338
    Profile photo of Andreas
    Andreas
    Moderator

    Same question still not answered: Which MIDI events do you send to turn off the Mute?

    #53340
    Profile photo of neptoon
    neptoon
    Participant

    Sorry about that, Well in cubase I set it to NOTE ON, So Guessing it would send a NOTE OFF on toggle? As for hex code that its sending i’m not 100% sure because I don’t have it set up that way. But I’m actually going to have a little bit of time tomorrow to sit down. I’m going to download a utility to try and figure out what CODE it’s sending through.

    #53476
    Profile photo of Andreas
    Andreas
    Moderator

    Sorry, out of office last week. Note OFF is surely the wrong event to be sent. The Mute is controlled by Note ON (90h) messages only, Mute ON uses a higher velocity (40h..7Fh) and Mute OFF expects a lower velocity (01h..3Fh). Each followed by an additional Note ON message for the same “note” with zero velocity.
    If this sounds somewhat weird, reason for this protocol is pretty simple: This way it does not create odd sounds on some synth module sharing the same MIDI cable, since the second Note ON with zero velocity is effectively defined to be interpreted as a Note OFF, any note triggered on a synth from the first Note ON event will be released immediatly.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.