Mixer Won't Respond to MIDI Commands

Forums Forums Qu Forums Qu troubleshooting Mixer Won't Respond to MIDI Commands

Tagged: 

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of volounteer volounteer 8 months, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #94434
    Profile photo of arretx
    arretx
    Participant

    I have the DAW control installed in OSX. The QU is set to channels 1 and 2 by default. A few days ago I had Ableton Live sending CC values to the QU-32 and the faders were responding. I was able to remotely control the faders on the main layer, not the custom layer. I can’t for the life of me figure out how I made it happen.

    I’m able to control the Custom Layer, but I can’t figure out, once a custom layer has an assigned function, to control that fader.

    I’m pretty sure I should be able to use CC values to control the main layer so I can fade in or out from a distance if I need to…or through automation. Any help would be appreciated. All software and firmware is up to date.

    #94437
    Profile photo of Alex A&H
    Alex A&H
    Keymaster

    Hi Arretx,

    It’s possible you were using the CC Translator option in the DAW Control driver for this. As this allows control of any of the input and output channel faders using simple CC messages.

    You can find information on this here: https://www.allen-heath.com/media/DAW-Control-Help-V1.71.pdf#page=5

    Thanks
    Alex

    #94450
    Profile photo of arretx
    arretx
    Participant

    Yep. I’ve been through it over and over again and I can’t make sense of the settings, and I know how to use MIDI. (you might think…do you…really?) Yep.

    Here’s what I’ve experienced. When I run the DAW translator and I select CC mode as the translator, Ableton Live offers me two input and two output options. According to the manual, the Input options are what need to be selected.

    Now, if I set a channel in Ableton Live to output MIDI to channel 2 (Default DAW control on the QU) on the resulting Daw Control remote MIDI output selection, and then I draw a curve on one of the CC values, the only fader that moves is the 7th fader in on the board.

    It doesn’t matter which CC value I send, it’s always the 7th fader. Additionally, if I draw a curve on two different CC values in the same MIDI clip, where I would expect each CC value to map to a different fader, those two values conflict with each other and fader 7 goes haywire trying to keep up with the most recent message.

    When I switch the translator to Mackie mode, and I select the appropriate outputs for MIDI in Ableton, I can effectively control the faders but only on the custom layer, which results in a neat show of mechanics, but if I map any custom layer to any function other than MIDI, of course, they don’t respond.

    Definitely going out of my mind.

    #94452
    Profile photo of volounteer
    volounteer
    Participant

    @arretex

    is this really a Qu problem or could it be your DAW software and driver?

    #94454
    Profile photo of arretx
    arretx
    Participant

    All other MIDI applications are in order. It’s a MAC. There’s minimal if any driver maintenance. Just the DAW translator by A&H.

    #94471
    Profile photo of Alex A&H
    Alex A&H
    Keymaster

    Hi Arretx,

    With CC Translator selected on the DAW Control Driver, you should see CC Translator Inputs and CC Translator Outputs as MIDI ports available in Ableton.

    If you want to control the input channel faders on your Qu from Ableton, you need to select the CC Translator Inputs port as the destination for your MIDI fader in Ableton.

    The MIDI from Ableton should match the MIDI Channel set on the desk (N), not the DAW Control MIDI Channel (N+1).

    Could you post screen shots of how you have the DAW Control Driver set up and an example of your set up in Ableton?

    Thanks
    Alex

    #94472
    Profile photo of SteffenR
    SteffenR
    Participant

    Alex the MIDI wizard has spoken… didn’t understand a damn thing… 🙂

    #94511
    Profile photo of arretx
    arretx
    Participant

    What in the world. Okay, so today it’s working as expected.

    To be safe, I cleared out ALL MIDI settings in Ableton Live and started from scratch.

    I have DAW control set to Channel 1, QU Series, CC.

    In Ableton Live, I have two MIDI routings for both input and output labeled CC Translator Inputs and CC Translater Outputs.

    I select Track ON and Remote ON for CC Translater Inputs, draw a curve in a MIDI clip for CC value 1, and sure enough, fader 1 is following that setting.

    Derp.

    Attachments:
    You must be logged in to view attached files.
    #94515
    Profile photo of volounteer
    volounteer
    Participant

    @arretex

    Great!

    Now put back all those other midi settings you had one by one and see when it stops working.
    Too many? Specific one? Combination?
    There is a reason it did not work before.
    Or did you make any other changes in anything near or in any of the devices?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.