GLD 112 Start-up Screen is Corrupted

Forums Forums GLD Forums GLD troubleshooting GLD 112 Start-up Screen is Corrupted

This topic contains 4 replies, has 4 voices, and was last updated by Profile photo of GCumbee GCumbee 4 years, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #51167
    Profile photo of Leye
    Leye
    Participant

    Could someone please explain to me how to fix this.
    I recently just got the GLD112 Series about 5-6 months ago. Loving it but then this happened… and I’m not sure how to fix it.
    GLD-112 Screen Error
    It wasn’t updated at first when it showed this, so I turned it off; unpluged everything; waited for a while, and then turned it back on.
    It took to me the “GLD wasn’t shutdown properly screen”
    I went to the advanced setting and quickly updated the firmware to v1.5 in the hopes that it will fix it.
    But no luck…
    I’ve tried everything I could think possible. I’m currently out of ideas.
    Could someone please help me. Thank you.

    Attachments:
    You must be logged in to view attached files.
    #51175
    Profile photo of Edi
    Edi
    Participant

    From the picture you attached, my first thought is, that it looks like a hardware defect, but you write about a corrupted start up screen…

    Are all other screens fine and only the home screen is distorted?
    If so, have you tried to do a factory reset?

    I don’t know, if it helps… Just an idea…

    #51187
    Profile photo of Nicola A&H
    Nicola A&H
    Keymaster

    Hi Leye,

    I suggest you get in touch with our local distributor as they are best placed to assist you. Alternatively you can submit a ticket to our UK Support team here: http://support.allen-heath.com/

    #51189
    Profile photo of Leye
    Leye
    Participant

    Hey Edi,
    From the start-up of the mixer to the home screen, the screen looked distorted.
    I didn’t try a factory reset because I didn’t make a backup for all my settings…(lesson learned);
    I returned it and I think they are shipping it back to the manufacturer for repairs. Now, I have to wait 1-2 months before I could get it back.
    Thanks Edi

    #51191
    Profile photo of GCumbee
    GCumbee
    Participant

    There is no factory reset on the GLD. Not sure why. There is on QU.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.