Faders not working SQ5

Forums Forums SQ Forums SQ troubleshooting Faders not working SQ5

This topic contains 7 replies, has 4 voices, and was last updated by Profile photo of Samuel S Samuel S 1 week, 2 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #104421
    Profile photo of dhuijberts
    dhuijberts
    Participant

    Hi everybody,

    Today I turned my SQ5 on, and de faders are not moving.
    I can move them up and down and the volumes will change, but when I switch to a different layer the faders won’t move.

    What can I do, can I reset something or check something

    #104424
    Profile photo of Mike C
    Mike C
    Participant

    When you change layers do the scribble strips change and indicate
    what the fader assignment is on that layer?

    What happens with the faders if you select a mix to put the faders to the
    sends on fade mode?

    Try a hard reset of the mixer and or a firmware update or re-load.
    Back up the mixer first.

    #104428
    Profile photo of ioTon
    ioTon
    Participant

    looks like a powersupply / hardware problem

    But of course you can try fader calibration…

    greetings

    #104429
    Profile photo of dhuijberts
    dhuijberts
    Participant

    yes, the scribble strips change..

    it makes no differents, i can select every layer, faders won’t move.

    #104431
    Profile photo of Mike C
    Mike C
    Participant

    Sounds like it’s about time to contact your dealer or Allen Heath.

    #104432
    Profile photo of Samuel S
    Samuel S
    Participant

    Hi dhuijberts,

    This happened to me two years ago with an SQ-6. I sent it for warranty repair. They found that the console had been exposed to too much dirt and debris from outdoor shows. They had to replace all the faders and the circuit board that connects the faders. In my case, it was around $300-500 if I remember correctly. I’m not sure if your cause is the same, but the symptoms you shared are exactly what mine were.

    #104441
    Profile photo of dhuijberts
    dhuijberts
    Participant

    I send the mixer back on Monday for repair,
    I wonder if this is covered by the warranty.
    you can expect it to be built against dirt.

    #104496
    Profile photo of Samuel S
    Samuel S
    Participant

    Nice, I hope warranty does cover it for you. I can’t remember if warranty covered part of my repair or not. I was sort of bummed that debris was able to get into the console and mess up the faders. I too was expecting the unit to be able to handle the “elements” a lot better. But I’ve learned that maintenance is absolutely essential at least in the SQ series.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.