Scene recall error

Forums Forums iLive Forums Archived iLive Discussions Scene recall error

This topic contains 7 replies, has 4 voices, and was last updated by Profile photo of pealsound pealsound 8 years, 8 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #23090
    Profile photo of AndyCZ
    AndyCZ
    Participant

    Hi Guys,

    Got a strange one here. I am running a combination of IDR48 (+M-MADI) and a T112 surface, all running v1.83 software. The system is currently in use on a theatrical tour, using CSC ShowControl v3 to send MIDI program changes to the surface.

    The problem is thus: When CSC boots, it initially sends a MIDI ‘All notes off’ reset command to the surface. When I then try to issue further scene recalls, either by sending program changes via MIDI or via the scene manager screen on the surface, the system keeps recalling the same memory. This can be any memory in the scene list. However, to confuse matters, the recall sometimes works fine. Other times, the surface will recall the target memory I am trying to access and then around half a second later will jump back to the ‘stuck’ memory. First discovered this during a show!!

    Re-booting the surface doesn’t make any difference, I have to shut the whole system down and re-start to clear the error, and then make sure CSC boots without the MIDI lead connected to the surface.

    The system also contains an RME ADAT/MADI bridge, which acts as the main 48kHz clock source, but I have had the error when the MixRack has used its internal clock.

    Help!!

    #30319
    Profile photo of Stix
    Stix
    Participant

    Does CSC send the all notes off on all midi channels? If not you could perhaps change the ilive to another midi channel or use a midi translator program to change or filter the midi data to just program change messages.

    Cheers

    Richard Howey
    Audio Dynamite Ltd
    IDR48/IDR16/T112/R72/Mixpad,Tweak,
    Dual M-Dante/DVS, 17″MBP/Logic 9/Custom Mackie Control

    #30320
    Profile photo of AndyCZ
    AndyCZ
    Participant

    Cheers Richard, I’ll check on that when I have the system up and running tomorrow, and report back.

    #30321
    Profile photo of RayS
    RayS
    Participant

    quote:


    Originally posted by AndyCZ

    Cheers Richard, I’ll check on that when I have the system up and running tomorrow, and report back.


    The first thing to check is whether or not the scene recall works ok without midi connected…..after that you should monitor the messages sent by csc and received by the iLive…I use snoize midi monitor http://www.snoize.com/MIDIMonitor/, although this sounds like midi loop back……

    RayS

    R-72/iDR32/iPS10

    #30335
    Profile photo of AndyCZ
    AndyCZ
    Participant

    quote:


    The first thing to check is whether or not the scene recall works ok without midi connected


    No – when using the scene recall from scene manager, it still causes the error.

    quote:


    although this sounds like midi loop back……


    I know what you mean, although in this instance the only MIDI connection is from the RME Fireface UFX into the T112.

    I’ll have a try with the Snoize monitor, cheers for that.

    #30338
    Profile photo of RayS
    RayS
    Participant

    quote:


    Originally posted by AndyCZ

    quote:


    Quote:
    although this sounds like midi loop back……


    I know what you mean, although in this instance the only MIDI connection is from the RME Fireface UFX into the T112.

    I’ll have a try with the Snoize monitor, cheers for that.


    Andy , there needs to be no midi connection at all for you to test the iLive’s scene recall.
    Only after you have made sure it all works as it should and that the scenes” behave” should you proceed by adding more and more components.

    RayS

    #30345
    Profile photo of AndyCZ
    AndyCZ
    Participant

    quote:


    Andy , there needs to be no midi connection at all for you to test the iLive’s scene recall.
    Only after you have made sure it all works as it should and that the scenes” behave” should you proceed by adding more and more components.


    I think that’s fairly obvious! [:p]

    Probably not made this clear – the sending of the MIDI ‘All notes off’ command is what causes the error in the first place. Then, scene recall will work erroneously as described in my original post,
    irrespective of whether the MIDI lead is connected or not.

    #31764
    Profile photo of pealsound
    pealsound
    Participant

    I’ve just found this tread. I had massive crashing problems caused by midi data arriving in a burst at the midi input port on the T112 surface. The solution was to roll back to firmware 1.81 and the problem no longer happened.

    I’ve now just had a crash recalling a scene….

    IDR48 – T112 – Dante card

Viewing 8 posts - 1 through 8 (of 8 total)

The forum ‘Archived iLive Discussions’ is closed to new topics and replies.