Reply To: QU-Pad 1.8 with QU-16 1.7 – WHY

Forums Forums Qu Forums Qu troubleshooting QU-Pad 1.8 with QU-16 1.7 – WHY Reply To: QU-Pad 1.8 with QU-16 1.7 – WHY

#52645
Profile photo of robbocurry
robbocurry
Participant

I understand your hesitancy about upgrading before a gig, but I’ve done at least ten firmware updates over three different QU’s and never had a glitch.
Version 1.8x has been working fine for me with no hiccups. I suppose it’s down to how much you really need to use the iPad at your next gig….
Personally I’d do the upgrade!