Reply To: QU-Pad 1.7 is needed for iPad 1st generation

Forums Forums Qu Forums Qu troubleshooting QU-Pad 1.7 is needed for iPad 1st generation Reply To: QU-Pad 1.7 is needed for iPad 1st generation

#51836
Profile photo of Fady
Fady
Participant

Just to update you guys, I managed to download QU-PAD 7 (Older version) on my iPad 1st generation & it works very well with matched firmware on QU-16. I’ll consider buying newer iPad soon but for now, it does the job nicely. Thanks a lot for your help & support!