2715

#34229
Profile photo of John-S
John-S
Participant

Yes, It is confirmed. If you do not need the iPad app then by all means upgrade your GLD. You cannot use the present iPad app (V1.10) with the new GLD80 software (V1.20). I had to downgrade as I needed the iPad app to mix monitors from the stage this Saturday.

While I had V1.20 loaded I must say I loved the new features. Sweet!!! Makes me feel I invested in a GLD80 rather than simply bought one.

I hope A&H sends out a notice when the app is upgraded. Should be soon I guess.

John