1665

#28655
Profile photo of Biggsounds
Biggsounds
Participant

I think you just need to have 1.80 or later – I haven’t updated since 1.80 but there’d be plenty of users here using MixPad with 1.82… I find the only stability issues I have are router issues, nothing to do with the software.
PS Buy it, you won’t regret the investment!

iDR32 mixrack
MixRack for iPad & Tweak for iPhone apps
Asus N61 Laptop (x2 wireless)
Windows 7 Pro 64bit
with Belkin PlayMax N600 HD router
Sennheiser IEM (for PFL)
Dante card